<!DOCTYPE html>
<html lang="en-GB">

<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.linuxlinks.com/xmlrpc.php">


	<!-- This site is optimized with the Yoast SEO plugin v15.0 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Excellent Utilities: Ananicy - auto nice daemon - LinuxLinks</title>
	<meta name="description" content="Ananicy is a shell daemon created to manage processes&#039; IO and CPU priorities, with community-driven set of rules for popular applications." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.linuxlinks.com/excellent-utilities-ananicy-auto-nice-daemon/" />
	<link rel="next" href="https://www.linuxlinks.com/excellent-utilities-ananicy-auto-nice-daemon/2/" />
	<meta property="og:locale" content="en_GB" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Excellent Utilities: Ananicy - auto nice daemon - LinuxLinks" />
	<meta property="og:description" content="Ananicy is a shell daemon created to manage processes&#039; IO and CPU priorities, with community-driven set of rules for popular applications." />
	<meta property="og:url" content="https://www.linuxlinks.com/excellent-utilities-ananicy-auto-nice-daemon/" />
	<meta property="og:site_name" content="LinuxLinks" />
	<meta property="article:published_time" content="2019-10-04T06:43:39+00:00" />
	<meta property="article:modified_time" content="2020-09-01T12:41:36+00:00" />
	<meta property="og:image" content="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2019/07/Tusk-arrows.jpg?fit=700%2C233&#038;ssl=1" />
	<meta property="og:image:width" content="700" />
	<meta property="og:image:height" content="233" />
	<meta name="twitter:card" content="summary_large_image" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.linuxlinks.com/#website","url":"https://www.linuxlinks.com/","name":"LinuxLinks","description":"The Linux Portal Site","potentialAction":[{"@type":"SearchAction","target":"https://www.linuxlinks.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-GB"},{"@type":"ImageObject","@id":"https://www.linuxlinks.com/excellent-utilities-ananicy-auto-nice-daemon/#primaryimage","inLanguage":"en-GB","url":"https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2019/07/Tusk-arrows.jpg?fit=700%2C233&ssl=1","width":700,"height":233,"caption":"Utilities"},{"@type":"WebPage","@id":"https://www.linuxlinks.com/excellent-utilities-ananicy-auto-nice-daemon/#webpage","url":"https://www.linuxlinks.com/excellent-utilities-ananicy-auto-nice-daemon/","name":"Excellent Utilities: Ananicy - auto nice daemon - LinuxLinks","isPartOf":{"@id":"https://www.linuxlinks.com/#website"},"primaryImageOfPage":{"@id":"https://www.linuxlinks.com/excellent-utilities-ananicy-auto-nice-daemon/#primaryimage"},"datePublished":"2019-10-04T06:43:39+00:00","dateModified":"2020-09-01T12:41:36+00:00","author":{"@id":"https://www.linuxlinks.com/#/schema/person/4770e5f50f65b33764e052ca2a0c67f6"},"description":"Ananicy is a shell daemon created to manage processes' IO and CPU priorities, with community-driven set of rules for popular applications.","inLanguage":"en-GB","potentialAction":[{"@type":"ReadAction","target":["https://www.linuxlinks.com/excellent-utilities-ananicy-auto-nice-daemon/"]}]},{"@type":"Person","@id":"https://www.linuxlinks.com/#/schema/person/4770e5f50f65b33764e052ca2a0c67f6","name":"Steve Emms","image":{"@type":"ImageObject","@id":"https://www.linuxlinks.com/#personlogo","inLanguage":"en-GB","url":"https://secure.gravatar.com/avatar/750ae96c2af861c4c3619ad9e7ac244b?s=96&d=identicon&r=g","caption":"Steve Emms"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="LinuxLinks &raquo; Feed" href="https://www.linuxlinks.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinuxLinks &raquo; Comments Feed" href="https://www.linuxlinks.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinuxLinks &raquo; Excellent Utilities: Ananicy &#8211; auto nice daemon Comments Feed" href="https://www.linuxlinks.com/excellent-utilities-ananicy-auto-nice-daemon/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.12.3 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
    (window.gaDevIds=window.gaDevIds||[]).push("dZGIzZG");
	var mi_version         = '7.12.3';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-1447713-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-1447713-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.linuxlinks.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='gambit-custom-fonts-css'  href='https://www.linuxlinks.com/wp-content/themes/gambit/assets/css/custom-fonts.css?ver=20180413' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.5.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='quads-style-css-css'  href='https://www.linuxlinks.com/wp-content/plugins/quick-adsense-reloaded/includes/gutenberg/dist/blocks.style.build.css?ver=2.0.14' type='text/css' media='all' />
<link rel='stylesheet' id='gambit-stylesheet-css'  href='https://www.linuxlinks.com/wp-content/themes/gambit/style.css?ver=1.6.5' type='text/css' media='all' />
<style id='gambit-stylesheet-inline-css' type='text/css'>
.site-description { position: absolute; clip: rect(1px, 1px, 1px, 1px); width: 1px; height: 1px; overflow: hidden; }
</style>
<link rel='stylesheet' id='genericons-css'  href='https://c0.wp.com/p/jetpack/9.0.2/_inc/genericons/genericons/genericons.css' type='text/css' media='all' />
<link rel='stylesheet' id='themezee-related-posts-css'  href='https://www.linuxlinks.com/wp-content/themes/gambit/assets/css/themezee-related-posts.css?ver=20160421' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://www.linuxlinks.com/wp-content/tablepress-combined.min.css?ver=36' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://www.linuxlinks.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/9.0.2/css/jetpack.css' type='text/css' media='all' />
<style id='quads-styles-inline-css' type='text/css'>
.quads-ad-label { font-size: 12px; text-align: center; color: #333;}
</style>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.1/wp-includes/js/jquery/jquery.js' id='jquery-core-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/related-posts/related-posts.min.js' id='jetpack_related-posts-js'></script>
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.linuxlinks.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxlinks.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.12.3' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://www.linuxlinks.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.linuxlinks.com/wp-content/themes/gambit/assets/js/html5shiv.min.js?ver=3.7.3' id='html5shiv-js'></script>
<![endif]-->
<script type='text/javascript' id='gambit-jquery-navigation-js-extra'>
/* <![CDATA[ */
var gambit_menu_title = "Menu";
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxlinks.com/wp-content/themes/gambit/assets/js/navigation.js?ver=20160719' id='gambit-jquery-navigation-js'></script>
<link rel="https://api.w.org/" href="https://www.linuxlinks.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.linuxlinks.com/wp-json/wp/v2/posts/38888" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.linuxlinks.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.linuxlinks.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.1" />
<link rel='shortlink' href='https://wp.me/p9swuV-a7e' />
<link rel="alternate" type="application/json+oembed" href="https://www.linuxlinks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxlinks.com%2Fexcellent-utilities-ananicy-auto-nice-daemon%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.linuxlinks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxlinks.com%2Fexcellent-utilities-ananicy-auto-nice-daemon%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};a2a_localize = {
	Share: "Share",
	Save: "Save",
	Subscribe: "Subscribe",
	Email: "Email",
	Bookmark: "Bookmark",
	ShowAll: "Show All",
	ShowLess: "Show less",
	FindServices: "Find service(s)",
	FindAnyServiceToAddTo: "Instantly find any service to add to",
	PoweredBy: "Powered by",
	ShareViaEmail: "Share via email",
	SubscribeViaEmail: "Subscribe via email",
	BookmarkInYourBrowser: "Bookmark in your browser",
	BookmarkInstructions: "Press Ctrl+D or \u2318+D to bookmark this page",
	AddToYourFavorites: "Add to your favourites",
	SendFromWebOrProgram: "Send from any email address or email program",
	EmailProgram: "Email program",
	More: "More&#8230;",
	ThanksForSharing: "Thanks for sharing!",
	ThanksForFollowing: "Thanks for following!"
};

(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type="text/javascript" src="https://www.linuxlinks.com/wp-content/plugins/quick-adsense-reloaded/assets/js/ads.js"></script><script type='text/javascript'>document.cookie = 'quads_browser_width='+screen.width;</script><style type='text/css'>img#wpstats{display:none}</style><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
					<style type="text/css" id="wp-custom-css">
				a:link,
a:visited {
  color: #00008B;
}
.widget-header {
	background: #00008B;
}

.site-title a:link,
.site-title a:visited {
	color: #00008B;
	
}

.header-main {
padding: 0.5em;
}

.main-navigation-menu ul {
	background: #00008B
}


.site-title {
	font-size: 32px;
	margin: 0.5em 0;
	line-height: 0;
}
.primary-navigation-wrap {
	background: #00008B;
}

body,
button,
input,
select,
textarea {
	color: #000000;
	font-size: 12px;
	font-size: 0.9375rem;
	font-family: Oxygen, Verdana, Georgia, Tahoma, Arial;
	line-height: 1.5;
}

code {
  padding: 2px 4px;
  font-size: 90%;
  color: #000000;
  background-color: #e2e2e2;
  border-radius: 2px;
}

/* Colored Content Boxes */

.box-blue,
.box-gray,
.box-green,
.box-grey,
.box-red,
.box-yellow {
	margin:0 0 25px;
	overflow:hidden;
	padding:20px;
	-webkit-border-radius: 10px;
        border-radius: 10px; 
}

.box-blue {
	background-color:#d8ecf7;
	border:1px solid #afcde3;
}

.box-gray {
	background-color:#e2e2e2;
	border:1px solid #bdbdbd;
}

.box-green {
	background-color:#d9edc2;
	border:1px solid #b2ce96;
}

.box-grey {
	background-color:#F5F5F5;
	border:1px solid #DDDDDD;
}

.box-red {
	background-color:#f9dbdb;
	border:1px solid #e9b3b3;
}

.box-yellow {
	background-color:#fef5c4;
	border:1px solid #fadf98;
}			</style>
		</head>

<body class="post-template-default single single-post postid-38888 single-format-standard wp-embed-responsive content-center">

	<div id="page" class="hfeed site">

		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		
		<header id="masthead" class="site-header clearfix" role="banner">

			<div class="header-main container clearfix">

				<div id="logo" class="site-branding clearfix">

										
			<p class="site-title"><a href="https://www.linuxlinks.com/" rel="home">LinuxLinks</a></p>

							
			<p class="site-description">The Linux Portal Site</p>

		
				</div><!-- .site-branding -->

				<div class="header-widgets clearfix">

					
				</div><!-- .header-widgets -->


			</div><!-- .header-main -->

		</header><!-- #masthead -->

		<div id="main-navigation-wrap" class="primary-navigation-wrap">

			<nav id="main-navigation" class="primary-navigation container navigation clearfix" role="navigation">
				<ul id="menu-test2" class="main-navigation-menu"><li id="menu-item-7623" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-7623"><a href="https://www.linuxlinks.com/">Home</a></li>
<li id="menu-item-56622" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-56622"><a href="https://www.linuxlinks.com/best-free-open-source-software/">Best Software</a></li>
<li id="menu-item-6330" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-6330"><a href="https://www.linuxlinks.com/links/">Linux Links Directory</a>
<ul class="sub-menu">
	<li id="menu-item-7559" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7559"><a href="https://www.linuxlinks.com/links/Distributions/">Distributions</a></li>
	<li id="menu-item-7560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7560"><a href="https://www.linuxlinks.com/links/Software/">Software</a></li>
	<li id="menu-item-7561" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7561"><a href="https://www.linuxlinks.com/links/UserGroups/">UserGroups</a></li>
	<li id="menu-item-7562" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7562"><a href="https://www.linuxlinks.com/links/Web/">Web Software</a></li>
	<li id="menu-item-7563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7563"><a href="https://www.linuxlinks.com/links/Java">Java</a></li>
</ul>
</li>
<li id="menu-item-31983" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31983"><a href="https://www.linuxlinks.com/category/reviews/">Reviews</a></li>
<li id="menu-item-12891" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12891"><a href="https://www.linuxlinks.com/award-winning-open-source-software/">OSS Awards</a></li>
<li id="menu-item-7639" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7639"><a href="https://www.linuxlinks.com/submit-news/">Contact Us</a></li>
</ul>			</nav><!-- #main-navigation -->

		</div>

		<div id="content-wrap" class="site-content-wrap clearfix">

			
			
			<div id="content" class="site-content container clearfix">

	<section id="primary" class="content-area">
		<main id="main" class="site-main" role="main">
				
		
<article id="post-38888" class="post-38888 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews category-software category-utilities tag-cpu tag-daemon tag-nice tag-priority tag-python">

	<img width="700" height="233" src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2019/07/Tusk-arrows.jpg?resize=700%2C233&amp;ssl=1" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="Utilities" loading="lazy" data-lazy-src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2019/07/Tusk-arrows.jpg?resize=700%2C233&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />
	<header class="entry-header">

		<h1 class="entry-title">Excellent Utilities: Ananicy &#8211; auto nice daemon</h1>
		<div class="entry-meta"><span class="meta-date"><a href="https://www.linuxlinks.com/excellent-utilities-ananicy-auto-nice-daemon/" title="7:43 am" rel="bookmark"><time class="entry-date published updated" datetime="2019-10-04T07:43:39+01:00">October 4, 2019</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://www.linuxlinks.com/author/linuxlinks/" title="View all posts by Steve Emms" rel="author">Steve Emms</a></span></span><span class="meta-category"> <a href="https://www.linuxlinks.com/category/reviews/" rel="category tag">Reviews</a>, <a href="https://www.linuxlinks.com/category/software/" rel="category tag">Software</a>, <a href="https://www.linuxlinks.com/category/utilities/" rel="category tag">Utilities</a></span></div>
	</header><!-- .entry-header -->

	<div class="entry-content clearfix">

		<p>This is a new series highlighting best-of-breed utilities. We’ll be covering a wide range of utilities including tools that boost your productivity, help you manage your workflow, and lots more besides. There&#8217;s a complete list of the tools in this series in the Summary section.</p>
<p>It&#8217;s possible to grant more importance to a process, giving it more time on the CPU. This property of a process is called niceness. A process with high priority is said to be less nice because it&#8217;s taking more of the CPU&#8217;s time, which leaves less for everything else. Alternatively, a process with low priority (a “nice” process) gets processor time only after other processes with higher priority have been serviced.</p>
<p>Prioritize applications&#8217; CPU and IO scheduling is a good way to improve performance on what really matters. This can be actioned per command with nice and ionice commands, but there&#8217;s a better way. Ananicy is a shell daemon created to manage processes&#8217; IO and CPU priorities, with community-driven set of rules for popular applications.</p>
<!-- WP QUADS Content Ad Plugin v. 2.0.14 -->
<div class="quads-location quads-ad2" id="quads-ad2" style="float:none;margin:-2px 0 -2px 0;text-align:center;">
<ins class="adsbygoogle"
   style="display:inline-block;min-width:300px;max-width:970px;width:100%;height:90px"
   data-ad-client="pub-6097899789476875"
   data-ad-slot="8494081652"></ins>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>

<p>It&#8217;s free and open source software written in Python.</p>
<h3>Installation</h3>
<p>Let&#8217;s clone the project&#8217;s repository, compile, and install the system with a few simple commands:</p>
<div class="box-grey">
$ git clone https://github.com/Nefelim4ag/Ananicy.git<br />
$ cd Ananicy<br />
$ sudo make install
</div>
<p>If you want to create your own Debian package, replace sudo make install with make deb.</p>
<p>You&#8217;ll find packages for Ananicy in many popular Linux distributions.</p>
<p>You&#8217;ll need schedtool installed on your system. This is a utility that sets all CPU scheduling parameters.</p>
<p style="text-align: right;"><a href="/excellent-utilities-ananicy-auto-nice-daemon/2/"><strong>Next page: Page 2 &#8211; In Operation</strong></a></p>
<p><strong>Pages in this article:</strong><br />
<a href="/excellent-utilities-ananicy-auto-nice-daemon/"><strong>Page 1 &#8211; Introduction / Installation</strong></a><br />
<a href="/excellent-utilities-ananicy-auto-nice-daemon/2/"><strong>Page 2 &#8211; In Operation</strong></a><br />
<a href="/excellent-utilities-ananicy-auto-nice-daemon/3/"><strong>Page 3 &#8211; Summary</strong></a></p>
<hr />
<p>Complete list of articles in this series:</p>

<table id="tablepress-543" class="tablepress tablepress-id-543">
<thead>
<tr class="row-1">
	<th colspan="2" class="column-1"><strong>Excellent Utilities</strong></th>
</tr>
</thead>
<tbody>
<tr class="row-2">
	<td class="column-1"><strong><a href="/excellent-utilities-tmux-terminal-multiplexer-software/">tmux</a></strong></td><td class="column-2">A terminal multiplexer that offers a massive boost to your workflow</td>
</tr>
<tr class="row-3">
	<td class="column-1"><strong><a href="/excellent-utilities-lnav-log-file-navigator/">lnav</a></strong></td><td class="column-2">Advanced log file viewer for the small-scale; great for troubleshooting</td>
</tr>
<tr class="row-4">
	<td class="column-1"><strong><a href="/excellent-utilities-paperwork-personal-document-manager/">Paperwork</a></strong></td><td class="column-2">Designed to simplify the management of your paperwork</td>
</tr>
<tr class="row-5">
	<td class="column-1"><strong><a href="/excellent-utilities-abricotine-open-source-markdown-editor/">Abricotine</a></strong></td><td class="column-2">Markdown editor with inline preview functionality</td>
</tr>
<tr class="row-6">
	<td class="column-1"><strong><a href="/excellent-utilities-mdless-formatted-highlighted-view-markdown-files/">mdless</a></strong></td><td class="column-2">Formatted and highlighted view of Markdown files</td>
</tr>
<tr class="row-7">
	<td class="column-1"><strong><a href="/excellent-utilities-fkill-kill-processes-quick-easy/">fkill</a></strong></td><td class="column-2">Kill processes quick and easy</td>
</tr>
<tr class="row-8">
	<td class="column-1"><strong><a href="/excellent-utilities-tusk-evernote-desktop-software/">Tusk</a></strong></td><td class="column-2">An unofficial Evernote client with bags of potential</td>
</tr>
<tr class="row-9">
	<td class="column-1"><strong><a href="/excellent-utilities-ulauncher-application-launcher-linux/">Ulauncher</a></strong></td><td class="column-2">Sublime application launcher</td>
</tr>
<tr class="row-10">
	<td class="column-1"><strong><a href="/excellent-utilities-mcfly-navigate-shell-history/">McFly</a></strong></td><td class="column-2">Navigate through your bash shell history</td>
</tr>
<tr class="row-11">
	<td class="column-1"><strong><a href="/excellent-utilities-languagetool-style-and-grammar-checker/">LanguageTool</a></strong></td><td class="column-2">Style and grammar checker for 30+ languages</td>
</tr>
<tr class="row-12">
	<td class="column-1"><strong><a href="/excellent-utilities-peco-interactive-filtering-tool/">peco</a></strong></td><td class="column-2">Simple interactive filtering tool that's remarkably useful</td>
</tr>
<tr class="row-13">
	<td class="column-1"><strong><a href="/excellent-utilities-liquid-prompt-adaptive-prompt-bash-zsh/">Liquid Prompt</a></strong></td><td class="column-2">Adaptive prompt for Bash &amp; Zsh</td>
</tr>
<tr class="row-14">
	<td class="column-1"><strong><a href="/excellent-utilities-ananicy-auto-nice-daemon/">Ananicy</a></strong></td><td class="column-2">Shell daemon created to manage processes’ IO and CPU priorities</td>
</tr>
<tr class="row-15">
	<td class="column-1"><strong><a href="/excellent-utilities-cheat-sh-community-driven-cheat-sheet/">cheat.sh</a></strong></td><td class="column-2">Community driven unified cheat sheet</td>
</tr>
<tr class="row-16">
	<td class="column-1"><strong><a href="/excellent-utilities-ripgrep-recursively-search-directories-regex-pattern/">ripgrep</a></strong></td><td class="column-2">Recursively search directories for a regex pattern</td>
</tr>
<tr class="row-17">
	<td class="column-1"><strong><a href="/excellent-utilities-exa-replacement-ls/">exa</a></strong></td><td class="column-2">A turbo-charged alternative to the venerable ls command</td>
</tr>
<tr class="row-18">
	<td class="column-1"><strong><a href="/excellent-utilities-ocrmypdf-add-ocr-text-layer-scanned-pdfs/">OCRmyPDF</a></strong></td><td class="column-2">Add OCR text layer to scanned PDFs</td>
</tr>
<tr class="row-19">
	<td class="column-1"><strong><a href="/excellent-utilities-watson-cli-tool-track-time/">Watson</a></strong></td><td class="column-2">Track the time spent on projects</td>
</tr>
<tr class="row-20">
	<td class="column-1"><strong><a href="/excellent-utilities-fontpreview-search-preview-fonts/">fontpreview</a></strong></td><td class="column-2">Quickly search and preview fonts</td>
</tr>
<tr class="row-21">
	<td class="column-1"><strong><a href="/excellent-utilities-fd-superior-alternative-find/">fd</a></strong></td><td class="column-2">Wonderful alternative to the venerable find</td>
</tr>
</tbody>
</table>
<!-- #tablepress-543 from cache -->

<!-- WP QUADS Content Ad Plugin v. 2.0.14 -->
<div class="quads-location quads-ad3" id="quads-ad3" style="float:none;margin:0px;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive - Text Only -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1180843672"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related articles</em></h3>
</div><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="addtoany_header">Share this article</div><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.linuxlinks.com/excellent-utilities-ananicy-auto-nice-daemon/" data-a2a-title="Excellent Utilities: Ananicy – auto nice daemon"><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fexcellent-utilities-ananicy-auto-nice-daemon%2F&amp;linkname=Excellent%20Utilities%3A%20Ananicy%20%E2%80%93%20auto%20nice%20daemon" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fexcellent-utilities-ananicy-auto-nice-daemon%2F&amp;linkname=Excellent%20Utilities%3A%20Ananicy%20%E2%80%93%20auto%20nice%20daemon" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fexcellent-utilities-ananicy-auto-nice-daemon%2F&amp;linkname=Excellent%20Utilities%3A%20Ananicy%20%E2%80%93%20auto%20nice%20daemon" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fexcellent-utilities-ananicy-auto-nice-daemon%2F&amp;linkname=Excellent%20Utilities%3A%20Ananicy%20%E2%80%93%20auto%20nice%20daemon" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_linkedin" href="https://www.addtoany.com/add_to/linkedin?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fexcellent-utilities-ananicy-auto-nice-daemon%2F&amp;linkname=Excellent%20Utilities%3A%20Ananicy%20%E2%80%93%20auto%20nice%20daemon" title="LinkedIn" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_mix" href="https://www.addtoany.com/add_to/mix?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fexcellent-utilities-ananicy-auto-nice-daemon%2F&amp;linkname=Excellent%20Utilities%3A%20Ananicy%20%E2%80%93%20auto%20nice%20daemon" title="Mix" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fexcellent-utilities-ananicy-auto-nice-daemon%2F&amp;linkname=Excellent%20Utilities%3A%20Ananicy%20%E2%80%93%20auto%20nice%20daemon" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_hacker_news" href="https://www.addtoany.com/add_to/hacker_news?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fexcellent-utilities-ananicy-auto-nice-daemon%2F&amp;linkname=Excellent%20Utilities%3A%20Ananicy%20%E2%80%93%20auto%20nice%20daemon" title="Hacker News" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fexcellent-utilities-ananicy-auto-nice-daemon%2F&amp;linkname=Excellent%20Utilities%3A%20Ananicy%20%E2%80%93%20auto%20nice%20daemon" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>
		<div class="page-links">Pages: <span class="post-page-numbers current" aria-current="page">1</span> <a href="https://www.linuxlinks.com/excellent-utilities-ananicy-auto-nice-daemon/2/" class="post-page-numbers">2</a> <a href="https://www.linuxlinks.com/excellent-utilities-ananicy-auto-nice-daemon/3/" class="post-page-numbers">3</a></div>
	</div><!-- .entry-content -->

	<footer class="entry-footer">

		
			<div class="entry-tags clearfix">
				<span class="meta-tags">
					<a href="https://www.linuxlinks.com/tag/cpu/" rel="tag">cpu</a><a href="https://www.linuxlinks.com/tag/daemon/" rel="tag">daemon</a><a href="https://www.linuxlinks.com/tag/nice/" rel="tag">nice</a><a href="https://www.linuxlinks.com/tag/priority/" rel="tag">priority</a><a href="https://www.linuxlinks.com/tag/python/" rel="tag">Python</a>				</span>
			</div><!-- .entry-tags -->

				
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.linuxlinks.com/excellent-free-books-learn-forth/" rel="prev"><span class="screen-reader-text">Previous Post:</span>7 Excellent Free Books to Learn Forth</a></div><div class="nav-next"><a href="https://www.linuxlinks.com/linux-candy-cacafire-color-ascii-fire/" rel="next"><span class="screen-reader-text">Next Post:</span>Linux Candy: cacafire &#8211; Color ASCII Fire</a></div></div>
	</nav>
	</footer><!-- .entry-footer -->

</article>

<div id="comments" class="comments-area">

	
	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Share your Thoughts					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/excellent-utilities-ananicy-auto-nice-daemon/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=139785133&#038;postid=38888&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Share+your+Thoughts&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=transparent&#038;lang=en_GB&#038;jetpack_version=9.0.2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=0a535aefe5e3a76de2c02f44b3c18e1fce4f6f49#parent=https%3A%2F%2Fwww.linuxlinks.com%2Fexcellent-utilities-ananicy-auto-nice-daemon%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = true;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments -->
		
		</main><!-- #main -->
	</section><!-- #primary -->
	
		<section id="secondary" class="main-sidebar widget-area clearfix" role="complementary">

		
<!-- Quick Adsense Reloaded -->
<aside id="adswidget1-quick-adsense-reloaded-4" class="widget quads-ad1_widget clearfix"><div id="quads-ad1_widget" style="margin:0px 0px 0px 0px; padding:0px 0px 0px 0px; "><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Response -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1669640918"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center></div></aside>
		<aside id="recent-posts-2" class="widget widget_recent_entries clearfix">
		<div class="widget-header"><h3 class="widget-title">Recent Posts</h3></div>
		<ul>
											<li>
					<a href="https://www.linuxlinks.com/debuggers/">11 Best Free and Open Source Linux Debuggers</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/businessprocessmanagement/">Manage your Business with a Complete Software Solution</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/cachingsystems/">7 Best Free and Open Source Linux Caching Systems</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/linux-candy-xdecorations-holiday-lights/">Linux Candy: XDecorations &#8211; Holiday lights and more</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/orthodoxfilemanagers/">14 Best Free and Open Source Orthodox Linux File Managers</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/best-free-open-source-os-level-virtualization/">5 Best Free and Open Source OS-level Virtualization</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/excellent-free-tutorials-learn-html/">Excellent Free Tutorials to Learn HTML</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/networkinventorymanagement/">9 Best Free and Open Source Network Inventory Management</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/excellent-free-tutorials-learn-pike/">Excellent Free Tutorials to Learn Pike</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/networktools/">6 Best Free and Open Source Console Based Network &#8216;top&#8217; Tools</a>
									</li>
					</ul>

		</aside>
<!-- Quick Adsense Reloaded -->
<aside id="adswidget1-quick-adsense-reloaded-9" class="widget quads-ad1_widget clearfix"><div id="quads-ad1_widget" style="margin:0px 0px 0px 0px; padding:0px 0px 0px 0px; "><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Response -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1669640918"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center></div></aside><aside id="jetpack-search-filters-6" class="widget jetpack-filters widget_search clearfix">			<div id="jetpack-search-filters-6-wrapper" >
		<div class="jetpack-search-form">
<form role="search" method="get" class="search-form" action="https://www.linuxlinks.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field"
			placeholder="Search &hellip;"
			value="" name="s"
			title="Search for:" />
	</label>
	<button type="submit" class="search-submit">
		<span class="genericon-search"></span>
		<span class="screen-reader-text">Search</span>
	</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /></form>
</div></div></aside><aside id="text-13" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Luke&#8217;s Weekly Blog</h3></div>			<div class="textwidget"><div class="box-grey">
<p>Luke is currently writing his weekly blog about the <strong><a href="/category/blog/">AWOW AK41 Mini Desktop PC</a></strong>.</p>
<p>Other hardware: <strong><a href="/tag/raspberry-pi-4/">Raspberry Pi 4 single board computer</a></strong></p>
</div>
</div>
		</aside><aside id="text-14" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Data Science</h3></div>			<div class="textwidget"><div class="box-grey">
<p>Take our free interactive courses in data science. There&#8217;s our course for <strong><a href="/python-data-science/">Python using pandas and plotnine</a></strong>, and our course for <strong><a href="/r-rstudio-data-science/">R using ggplot2</a></strong>. </p>
<p>Get up to speed in 20 minutes. No programming knowledge required.</p>
</div>
</div>
		</aside><aside id="recent-comments-2" class="widget widget_recent_comments clearfix"><div class="widget-header"><h3 class="widget-title">Recent Comments</h3></div><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Connor Yves</span> on <a href="https://www.linuxlinks.com/mark-text-simple-elegant-markdown-distraction-free-editor/#comment-1273">Mark Text &#8211; simple and elegant open source Markdown editor</a></li><li class="recentcomments"><span class="comment-author-link">randint</span> on <a href="https://www.linuxlinks.com/mark-text-simple-elegant-markdown-distraction-free-editor/#comment-1272">Mark Text &#8211; simple and elegant open source Markdown editor</a></li><li class="recentcomments"><span class="comment-author-link">Dave Boland</span> on <a href="https://www.linuxlinks.com/anymeal/#comment-1270">AnyMeal &#8211; free recipe database software</a></li><li class="recentcomments"><span class="comment-author-link">Dereka B</span> on <a href="https://www.linuxlinks.com/compressiontools/#comment-1269">14 Best Free and Open Source Linux Compression Tools</a></li><li class="recentcomments"><span class="comment-author-link">Sorren69</span> on <a href="https://www.linuxlinks.com/r-rstudio-data-science/#comment-1268">Introduction to R and RStudio for Data Science</a></li></ul></aside><aside id="text-12" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Programming Books</h3></div>			<div class="textwidget"><div class="box-grey">
<p>Read our <strong><a href="/excellent-free-programming-books/">curated lists of great free programming books</a></strong>. Learn <strong><a href="/excellent-free-books-learn-java/">Java</a></strong>, <strong><a href="/excellent-free-books-learn-c/">C</a></strong>, <strong><a href="/excellent-free-books-learn-python/">Python</a></strong>, <strong><a href="/excellent-free-books-learn-c-plus-plus/">C++</a></strong>, <strong><a href="/excellent-free-books-learn-c-sharp/">C#</a></strong>, <strong><a href="/excellent-free-books-learn-javascript/">JavaScript</a></strong>, <strong><a href="/excellent-free-books-learn-php/">PHP</a></strong>, and many more languages.</p>
<p>Alternatively, check out our series of <strong><a href="/category/tutorials/">great free programming tutorials</a></strong>.</p>
</div>
</div>
		</aside><aside id="archives-6" class="widget widget_archive clearfix"><div class="widget-header"><h3 class="widget-title">Archives</h3></div>		<label class="screen-reader-text" for="archives-dropdown-6">Archives</label>
		<select id="archives-dropdown-6" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://www.linuxlinks.com/2020/10/'> October 2020 </option>
	<option value='https://www.linuxlinks.com/2020/09/'> September 2020 </option>
	<option value='https://www.linuxlinks.com/2020/08/'> August 2020 </option>
	<option value='https://www.linuxlinks.com/2020/07/'> July 2020 </option>
	<option value='https://www.linuxlinks.com/2020/06/'> June 2020 </option>
	<option value='https://www.linuxlinks.com/2020/05/'> May 2020 </option>
	<option value='https://www.linuxlinks.com/2020/04/'> April 2020 </option>
	<option value='https://www.linuxlinks.com/2020/03/'> March 2020 </option>
	<option value='https://www.linuxlinks.com/2020/02/'> February 2020 </option>
	<option value='https://www.linuxlinks.com/2020/01/'> January 2020 </option>
	<option value='https://www.linuxlinks.com/2019/12/'> December 2019 </option>
	<option value='https://www.linuxlinks.com/2019/11/'> November 2019 </option>
	<option value='https://www.linuxlinks.com/2019/10/'> October 2019 </option>
	<option value='https://www.linuxlinks.com/2019/09/'> September 2019 </option>
	<option value='https://www.linuxlinks.com/2019/08/'> August 2019 </option>
	<option value='https://www.linuxlinks.com/2019/07/'> July 2019 </option>
	<option value='https://www.linuxlinks.com/2019/06/'> June 2019 </option>
	<option value='https://www.linuxlinks.com/2019/05/'> May 2019 </option>
	<option value='https://www.linuxlinks.com/2019/04/'> April 2019 </option>
	<option value='https://www.linuxlinks.com/2019/03/'> March 2019 </option>
	<option value='https://www.linuxlinks.com/2019/02/'> February 2019 </option>
	<option value='https://www.linuxlinks.com/2019/01/'> January 2019 </option>
	<option value='https://www.linuxlinks.com/2018/12/'> December 2018 </option>
	<option value='https://www.linuxlinks.com/2018/11/'> November 2018 </option>
	<option value='https://www.linuxlinks.com/2018/10/'> October 2018 </option>
	<option value='https://www.linuxlinks.com/2018/09/'> September 2018 </option>
	<option value='https://www.linuxlinks.com/2018/08/'> August 2018 </option>
	<option value='https://www.linuxlinks.com/2018/07/'> July 2018 </option>
	<option value='https://www.linuxlinks.com/2018/06/'> June 2018 </option>
	<option value='https://www.linuxlinks.com/2018/05/'> May 2018 </option>
	<option value='https://www.linuxlinks.com/2018/04/'> April 2018 </option>
	<option value='https://www.linuxlinks.com/2018/03/'> March 2018 </option>
	<option value='https://www.linuxlinks.com/2018/02/'> February 2018 </option>
	<option value='https://www.linuxlinks.com/2018/01/'> January 2018 </option>
	<option value='https://www.linuxlinks.com/2017/12/'> December 2017 </option>
	<option value='https://www.linuxlinks.com/2017/11/'> November 2017 </option>
	<option value='https://www.linuxlinks.com/2017/10/'> October 2017 </option>
	<option value='https://www.linuxlinks.com/2017/09/'> September 2017 </option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-6" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</aside>
	</section><!-- #secondary -->
	<section id="secondary" class="small-sidebar widget-area clearfix" role="complementary">

		
<!-- Quick Adsense Reloaded -->
<aside id="adswidget1-quick-adsense-reloaded-8" class="widget quads-ad1_widget clearfix"><div id="quads-ad1_widget" style="margin:0px 0px 0px 0px; padding:0px 0px 0px 0px; "><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Response -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1669640918"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center></div></aside><aside id="text-16" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Recommended Software</h3></div>			<div class="textwidget">
<table id="tablepress-612" class="tablepress tablepress-id-612">
<tbody>
<tr class="row-1">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-documents/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Documents.png" alt="Documents" width="64" height="64" class="alignnone size-full wp-image-56405" /><br />
<strong>Documents</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-internet/"><img src="https://i2.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Internet.png" alt="Internet" width="62" height="64" class="alignnone size-full wp-image-56419" /><br />
<strong>Internet</strong></a></center></td>
</tr>
<tr class="row-2">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-graphics/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/palette.png" alt="Graphics" width="64" height="64" class="alignnone size-full wp-image-56421" /><br />
<strong>Graphics</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-video/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Videos-icon.png" alt="Videos" width="64" height="64" class="alignnone size-full wp-image-56439" /><br />
<strong>Video</strong></a></center></td>
</tr>
<tr class="row-3">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-audio/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/classic.png" alt="Audio" width="64" height="64" class="alignnone size-full wp-image-56382" /><br />
<strong>Audio</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-productivity/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Productivity.png" alt="Productivity" width="64" height="64" class="alignnone size-full wp-image-56417" /><br />
<strong>Productivity</strong></a></center></td>
</tr>
<tr class="row-4">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-science/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Science.png" alt="Science" width="64" height="64" class="alignnone size-full wp-image-56410" /><br />
<strong>Science</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-education/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Education.png" alt="Education" width="64" height="64" class="alignnone size-full wp-image-56412" /><br />
<strong>Education</strong></a></center></td>
</tr>
<tr class="row-5">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-system-administration/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/System-Admin.png" alt="System Administration" width="64" height="64" class="alignnone size-full wp-image-56432" /><br />
<strong>System Admin</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-desktop/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/desktop.png" alt="Desktop" width="64" height="64" class="alignnone size-full wp-image-56403" /><br />
<strong>Desktop</strong></a></center></td>
</tr>
<tr class="row-6">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-utilities/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Utilities.png" alt="Utilities" width="64" height="64" class="alignnone size-full wp-image-56423" /><br />
<strong>Utilities</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-development/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Programming.png" alt="Programming" width="64" height="64" class="alignnone size-full wp-image-56436" /><br />
<strong>Development</strong></a></center></td>
</tr>
<tr class="row-7">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-finance/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/finance.png" alt="finance" width="64" height="64" class="alignnone size-full wp-image-56396" /><br />
<strong>Finance</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-games/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Games-icon.png" alt="Games" width="64" height="64" class="alignnone size-full wp-image-56415" /><br />
<strong>Games</strong></a></center></td>
</tr>
<tr class="row-8">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-web-applications/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Web-apps.png" alt="Web Apps" width="64" height="64" class="alignnone size-full wp-image-56430" /><br />
<strong>Web Apps</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-security/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Security.png" alt="Security" width="64" height="64" class="alignnone size-full wp-image-56425" /><br />
<strong>Security</strong></a></center></td>
</tr>
<tr class="row-9">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-other-applications/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Other.png" alt="Other" width="64" height="64" class="alignnone size-full wp-image-56427" /><br />
<strong>Other</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-documentation/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Documentation.png" alt="Documentation" width="64" height="64" class="alignnone size-full wp-image-56434" /><br />
<strong>Documentation</strong></a></center><br />
</td>
</tr>
</tbody>
</table>
<!-- #tablepress-612 from cache -->
</div>
		</aside><aside id="text-11" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Reviews</h3></div>			<div class="textwidget"><div class="box-grey">We&#8217;ve written tons of in-depth and <span data-dobid="hdw">completely</span> impartial reviews of open source software. <strong><a href="/category/reviews/">Read our reviews</a></strong>.
</div>
</div>
		</aside><aside id="text-15" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Get Involved</h3></div>			<div class="textwidget"><div class="box-grey"><a href="/sponsor-donate-linuxlinks/"><strong>Donate</strong></a> to LinuxLinks. Your help is appreciated.</p>
<p><strong><a href="/sponsor-donate-linuxlinks/">Sponsorship opportunities</a></strong> &#8211; Have a product or service you wish to promote?
</div>
</div>
		</aside><aside id="text-9" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Desktops</h3></div>			<div class="textwidget"><div class="box-grey"><strong><a href="/survey-linux-desktop-environments/">9 Best Desktops</a></strong><br />
<strong><a href="/excellent-kde-plasma-widgets/">24 KDE Widgets</a></strong><br />
<strong><a href="/excellent-gnome-desktop-extensions/">33 GNOME Extensions</a></strong><br />
<strong><a href="/linux-desktop-environments-pantheon-trinity-lxde/">Pantheon, Trinity, LXDE</a></strong></div>
</div>
		</aside><aside id="text-10" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">System Tools</h3></div>			<div class="textwidget"><div class="box-grey">
<p>Manage your system with <strong><a href="/essential-system-tools-excellent-ways-manage-system/">27 essential system tools</a></strong>. We&#8217;ve written an in-depth review for each of them.</p>
<p>We&#8217;re also writing a series of reviews showcasing <strong><a href="/outstanding-linux-utilities-maximize-productivity/">excellent utilities</a></strong>.</p>
</div>
</div>
		</aside><aside id="eu_cookie_law_widget-3" class="widget widget_eu_cookie_law_widget clearfix">
<div
	class="hide-on-button"
	data-hide-timeout="30"
	data-consent-expiration="180"
	id="eu-cookie-law"
>
	<form method="post">
		<input type="submit" value="Close and accept" class="accept" />
	</form>

	Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
		<a href="https://www.linuxlinks.com/privacy-policy/" rel="">
		Cookie Policy	</a>
</div>
</aside><aside id="meta-2" class="widget widget_meta clearfix"><div class="widget-header"><h3 class="widget-title">Meta</h3></div>
		<ul>
						<li><a rel="nofollow" href="https://www.linuxlinks.com/wp-login.php">Log in</a></li>
			<li><a href="https://www.linuxlinks.com/feed/">Entries feed</a></li>
			<li><a href="https://www.linuxlinks.com/comments/feed/">Comments feed</a></li>

			<li><a href="https://en-gb.wordpress.org/">WordPress.org</a></li>
		</ul>

		</aside><aside id="text-8" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Related</h3></div>			<div class="textwidget"><p><a href="/link-us/">Link us</a><br />
<a href="/faq/">FAQ</a><br />
<a href="https://www.forfoss.com/">ForFOSS.com</a><br />
<a href="https://www.ossblog.org/">OSSBlog.org</a><br />
<a href="/privacy-policy/">Privacy Policy</a></p>
</div>
		</aside>
	</section><!-- #secondary -->
	

		</div><!-- #content -->

	</div><!-- #content-wrap -->

	
	<div id="footer" class="site-footer-wrap">

		<footer id="colophon" class="site-footer container clearfix" role="contentinfo">

			<div id="footer-text" class="site-info">
				
	<span class="credit-link">
		Copyright 2018-2020 LinuxLinks.com	</span>

				</div><!-- .site-info -->

			
		</footer><!-- #colophon -->

	</div>

</div><!-- #page -->

<script type="text/javascript">
   if(typeof quadsOptions !== 'undefined' && typeof wpquads_adblocker_check_2 
  === 'undefined' && quadsOptions.quadsChoice == 'ad_blocker_message'){

  var addEvent1 = function (obj, type, fn) {
      if (obj.addEventListener)
          obj.addEventListener(type, fn, false);
      else if (obj.attachEvent)
          obj.attachEvent('on' + type, function () {
              return fn.call(obj, window.event);
          });
  };
   addEvent1(window, 'load', function () {
      if (typeof wpquads_adblocker_check_2 === "undefined" || wpquads_adblocker_check_2 === false) {
          highlight_adblocked_ads();
      }
  });

   function highlight_adblocked_ads() {
      try {
          var ad_wrappers = document.querySelectorAll('div[id^="quads-ad"]')
      } catch (e) {
          return;
      }

      for (i = 0; i < ad_wrappers.length; i++) {
          ad_wrappers[i].className += ' quads-highlight-adblocked';
          ad_wrappers[i].className = ad_wrappers[i].className.replace('quads-location', '');
          ad_wrappers[i].setAttribute('style', 'display:block !important');
      }
  }
 }

(function() {
//Adblocker Notice Script Starts Here
var curr_url = window.location.href;
var red_ulr = localStorage.getItem('curr');
var modal = document.getElementById("quads-myModal");
var quadsAllowedCookie =  quadsgetCookie('quadsAllowedCookie');

if(typeof quadsOptions !== 'undefined' && typeof wpquads_adblocker_check_2 
  === 'undefined' ){

  if(quadsAllowedCookie!=quadsOptions.allow_cookies){
    quadssetCookie('quadsCookie', '', -1, '/');
    quadssetCookie('quadsAllowedCookie', quadsOptions.allow_cookies, 1, '/');
  }

  if(quadsOptions.allow_cookies == 2){
    if( quadsOptions.quadsChoice == 'bar' || quadsOptions.quadsChoice == 'popup'){
        modal.style.display = "block";
        quadssetCookie('quadsCookie', '', -1, '/');
    }
    
    if(quadsOptions.quadsChoice == 'page_redirect' && quadsOptions.page_redirect !="undefined"){
        if(red_ulr==null || curr_url!=quadsOptions.page_redirect){
        window.location = quadsOptions.page_redirect;
        localStorage.setItem('curr',quadsOptions.page_redirect);
      }
    }
  }else{
    var adsCookie = quadsgetCookie('quadsCookie');
    if(adsCookie==false) {
      if( quadsOptions.quadsChoice == 'bar' || quadsOptions.quadsChoice == 'popup'){
          modal.style.display = "block";
      }
      if(quadsOptions.quadsChoice == 'page_redirect' && quadsOptions.page_redirect !="undefined"){
        window.location = quadsOptions.page_redirect;
        quadssetCookie('quadsCookie', true, 1, '/');
      }
    }else{
      modal.style.display = "none";
    }
  }
}



var span = document.getElementsByClassName("quads-cls-notice")[0];
if(span){
  span.onclick = function() {
    modal.style.display = "none";
    document.cookie = "quads_prompt_close="+new Date();
    quadssetCookie('quadsCookie', 'true', 1, '/');
  }
}

window.onclick = function(event) {
  if (event.target == modal) {
    modal.style.display = "none";
    document.cookie = "quads_prompt_close="+new Date();
    quadssetCookie('quadsCookie', 'true', 1, '/');
  }
}
})();
function quadsgetCookie(cname){
    var name = cname + '=';
    var ca = document.cookie.split(';');
    for (var i = 0; i < ca.length; i++) {
        var c = ca[i].trim();
        if (c.indexOf(name) === 0) {
            return c.substring(name.length, c.length);
        }
    }
    return false;
}
function quadssetCookie(cname, cvalue, exdays, path){
  var d = new Date();
  d.setTime(d.getTime() + (exdays*24*60*60*1000));
  var expires = "expires="+ d.toUTCString();
  document.cookie = cname + "=" + cvalue + ";" + expires + ";path=/";
}
//Adblocker Notice Script Ends Here
</script>

<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.1/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js' id='eu-cookie-law-script-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.0.2/modules/widgets/search/js/search-widget.js' id='jetpack-search-widget-js'></script>
<script type='text/javascript' src='https://www.linuxlinks.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.0.0' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.1/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://www.linuxlinks.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6' id='akismet-form-js'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=139785133&postid=38888&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=identicon&greeting=Share+your+Thoughts&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_GB&jetpack_version=9.0.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0a535aefe5e3a76de2c02f44b3c18e1fce4f6f49#parent=https%3A%2F%2Fwww.linuxlinks.com%2Fexcellent-utilities-ananicy-auto-nice-daemon%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=139785133&postid=38888&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=identicon&greeting=Share+your+Thoughts&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_GB&jetpack_version=9.0.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0a535aefe5e3a76de2c02f44b3c18e1fce4f6f49#parent=https%3A%2F%2Fwww.linuxlinks.com%2Fexcellent-utilities-ananicy-auto-nice-daemon%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202041.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.0.2',blog:'139785133',post:'38888',tz:'1',srv:'www.linuxlinks.com'} ]);
	_stq.push([ 'clickTrackerInit', '139785133', '38888' ]);
</script>

</body>
</html>

<!-- Cached by WP-Optimize (gzip) - https://getwpo.com - Last modified: Sat, 10 Oct 2020 15:44:33 GMT -->
