<!DOCTYPE html>
<html lang="en-GB">

<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.linuxlinks.com/xmlrpc.php">


	<!-- This site is optimized with the Yoast SEO plugin v14.8 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Raspberry Pi 4: Chronicling the Desktop Experience – Retro Gaming – Week 17 - LinuxLinks</title>
	<meta name="description" content="For this week, I&#039;m going to look at a few retro games, all nestling in Raspbian&#039;s repositories. Free and open source gaming." />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.linuxlinks.com/raspberry-pi-4-chronicling-desktop-experience-retro-gaming/" />
	<meta property="og:locale" content="en_GB" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Raspberry Pi 4: Chronicling the Desktop Experience – Retro Gaming – Week 17 - LinuxLinks" />
	<meta property="og:description" content="For this week, I&#039;m going to look at a few retro games, all nestling in Raspbian&#039;s repositories. Free and open source gaming." />
	<meta property="og:url" content="https://www.linuxlinks.com/raspberry-pi-4-chronicling-desktop-experience-retro-gaming/" />
	<meta property="og:site_name" content="LinuxLinks" />
	<meta property="article:published_time" content="2020-02-19T07:58:27+00:00" />
	<meta property="article:modified_time" content="2020-04-12T17:19:43+00:00" />
	<meta property="og:image" content="https://i0.wp.com/www.linuxlinks.com/wp-content/uploads/2018/06/Gaming-Chat.jpg?fit=631%2C374&#038;ssl=1" />
	<meta property="og:image:width" content="631" />
	<meta property="og:image:height" content="374" />
	<meta name="twitter:card" content="summary_large_image" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.linuxlinks.com/#website","url":"https://www.linuxlinks.com/","name":"LinuxLinks","description":"The Linux Portal Site","potentialAction":[{"@type":"SearchAction","target":"https://www.linuxlinks.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-GB"},{"@type":"ImageObject","@id":"https://www.linuxlinks.com/raspberry-pi-4-chronicling-desktop-experience-retro-gaming/#primaryimage","inLanguage":"en-GB","url":"https://i0.wp.com/www.linuxlinks.com/wp-content/uploads/2018/06/Gaming-Chat.jpg?fit=631%2C374&ssl=1","width":631,"height":374,"caption":"Gaming Chat"},{"@type":"WebPage","@id":"https://www.linuxlinks.com/raspberry-pi-4-chronicling-desktop-experience-retro-gaming/#webpage","url":"https://www.linuxlinks.com/raspberry-pi-4-chronicling-desktop-experience-retro-gaming/","name":"Raspberry Pi 4: Chronicling the Desktop Experience \u2013 Retro Gaming \u2013 Week 17 - LinuxLinks","isPartOf":{"@id":"https://www.linuxlinks.com/#website"},"primaryImageOfPage":{"@id":"https://www.linuxlinks.com/raspberry-pi-4-chronicling-desktop-experience-retro-gaming/#primaryimage"},"datePublished":"2020-02-19T07:58:27+00:00","dateModified":"2020-04-12T17:19:43+00:00","author":{"@id":"https://www.linuxlinks.com/#/schema/person/f9d8c85cfa6a76d5864d19c7ead4d370"},"description":"For this week, I'm going to look at a few retro games, all nestling in Raspbian's repositories.\u00a0Free and open source gaming.","inLanguage":"en-GB","potentialAction":[{"@type":"ReadAction","target":["https://www.linuxlinks.com/raspberry-pi-4-chronicling-desktop-experience-retro-gaming/"]}]},{"@type":"Person","@id":"https://www.linuxlinks.com/#/schema/person/f9d8c85cfa6a76d5864d19c7ead4d370","name":"Luke Baker","image":{"@type":"ImageObject","@id":"https://www.linuxlinks.com/#personlogo","inLanguage":"en-GB","url":"https://secure.gravatar.com/avatar/f336cae4230411eda626efb39d19aadf?s=96&d=identicon&r=g","caption":"Luke Baker"},"description":"I've been using Linux seriously for the past couple of years. I'm a huge fan of the Arch and Manjaro distributions. And of course the Raspberry Pi."}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="LinuxLinks &raquo; Feed" href="https://www.linuxlinks.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinuxLinks &raquo; Comments Feed" href="https://www.linuxlinks.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinuxLinks &raquo; Raspberry Pi 4: Chronicling the Desktop Experience – Retro Gaming – Week 17 Comments Feed" href="https://www.linuxlinks.com/raspberry-pi-4-chronicling-desktop-experience-retro-gaming/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.12.2 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.12.2';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-1447713-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-1447713-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.linuxlinks.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='gambit-custom-fonts-css'  href='https://www.linuxlinks.com/wp-content/themes/gambit/assets/css/custom-fonts.css?ver=20180413' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.5/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='quads-style-css-css'  href='https://www.linuxlinks.com/wp-content/plugins/quick-adsense-reloaded/includes/gutenberg/dist/blocks.style.build.css?ver=2.0.10.2' type='text/css' media='all' />
<link rel='stylesheet' id='gambit-stylesheet-css'  href='https://www.linuxlinks.com/wp-content/themes/gambit/style.css?ver=1.6.5' type='text/css' media='all' />
<style id='gambit-stylesheet-inline-css' type='text/css'>
.site-description { position: absolute; clip: rect(1px, 1px, 1px, 1px); width: 1px; height: 1px; overflow: hidden; }
</style>
<link rel='stylesheet' id='genericons-css'  href='https://c0.wp.com/p/jetpack/8.8.2/_inc/genericons/genericons/genericons.css' type='text/css' media='all' />
<link rel='stylesheet' id='themezee-related-posts-css'  href='https://www.linuxlinks.com/wp-content/themes/gambit/assets/css/themezee-related-posts.css?ver=20160421' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://www.linuxlinks.com/wp-content/tablepress-combined.min.css?ver=36' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://www.linuxlinks.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.8.2/css/jetpack.css' type='text/css' media='all' />
<style id='quads-styles-inline-css' type='text/css'>
.quads-ad-label { font-size: 12px; text-align: center; color: #333;}
</style>
<script type='text/javascript' src='https://c0.wp.com/c/5.5/wp-includes/js/jquery/jquery.js' id='jquery-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.8.2/_inc/build/related-posts/related-posts.min.js' id='jetpack_related-posts-js'></script>
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.linuxlinks.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxlinks.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.12.2' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://www.linuxlinks.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.linuxlinks.com/wp-content/themes/gambit/assets/js/html5shiv.min.js?ver=3.7.3' id='html5shiv-js'></script>
<![endif]-->
<script type='text/javascript' id='gambit-jquery-navigation-js-extra'>
/* <![CDATA[ */
var gambit_menu_title = "Menu";
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxlinks.com/wp-content/themes/gambit/assets/js/navigation.js?ver=20160719' id='gambit-jquery-navigation-js'></script>
<link rel="https://api.w.org/" href="https://www.linuxlinks.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.linuxlinks.com/wp-json/wp/v2/posts/42389" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.linuxlinks.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.linuxlinks.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5" />
<link rel='shortlink' href='https://wp.me/p9swuV-b1H' />
<link rel="alternate" type="application/json+oembed" href="https://www.linuxlinks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxlinks.com%2Fraspberry-pi-4-chronicling-desktop-experience-retro-gaming%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.linuxlinks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxlinks.com%2Fraspberry-pi-4-chronicling-desktop-experience-retro-gaming%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};a2a_localize = {
	Share: "Share",
	Save: "Save",
	Subscribe: "Subscribe",
	Email: "Email",
	Bookmark: "Bookmark",
	ShowAll: "Show All",
	ShowLess: "Show less",
	FindServices: "Find service(s)",
	FindAnyServiceToAddTo: "Instantly find any service to add to",
	PoweredBy: "Powered by",
	ShareViaEmail: "Share via email",
	SubscribeViaEmail: "Subscribe via email",
	BookmarkInYourBrowser: "Bookmark in your browser",
	BookmarkInstructions: "Press Ctrl+D or \u2318+D to bookmark this page",
	AddToYourFavorites: "Add to your favourites",
	SendFromWebOrProgram: "Send from any email address or email program",
	EmailProgram: "Email program",
	More: "More&#8230;",
	ThanksForSharing: "Thanks for sharing!",
	ThanksForFollowing: "Thanks for following!"
};

(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type="text/javascript" src="https://www.linuxlinks.com/wp-content/plugins/quick-adsense-reloaded/assets/js/ads.js"></script><script type='text/javascript'>document.cookie = 'quads_browser_width='+screen.width;</script><style type='text/css'>img#wpstats{display:none}</style><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
					<style type="text/css" id="wp-custom-css">
				a:link,
a:visited {
  color: #00008B;
}
.widget-header {
	background: #00008B;
}

.site-title a:link,
.site-title a:visited {
	color: #00008B;
	
}

.header-main {
padding: 0.5em;
}

.main-navigation-menu ul {
	background: #00008B
}


.site-title {
	font-size: 32px;
	margin: 0.5em 0;
	line-height: 0;
}
.primary-navigation-wrap {
	background: #00008B;
}

body,
button,
input,
select,
textarea {
	color: #000000;
	font-size: 12px;
	font-size: 0.9375rem;
	font-family: Oxygen, Verdana, Georgia, Tahoma, Arial;
	line-height: 1.5;
}

code {
  padding: 2px 4px;
  font-size: 90%;
  color: #000000;
  background-color: #e2e2e2;
  border-radius: 2px;
}

/* Colored Content Boxes */

.box-blue,
.box-gray,
.box-green,
.box-grey,
.box-red,
.box-yellow {
	margin:0 0 25px;
	overflow:hidden;
	padding:20px;
	-webkit-border-radius: 10px;
        border-radius: 10px; 
}

.box-blue {
	background-color:#d8ecf7;
	border:1px solid #afcde3;
}

.box-gray {
	background-color:#e2e2e2;
	border:1px solid #bdbdbd;
}

.box-green {
	background-color:#d9edc2;
	border:1px solid #b2ce96;
}

.box-grey {
	background-color:#F5F5F5;
	border:1px solid #DDDDDD;
}

.box-red {
	background-color:#f9dbdb;
	border:1px solid #e9b3b3;
}

.box-yellow {
	background-color:#fef5c4;
	border:1px solid #fadf98;
}			</style>
		</head>

<body class="post-template-default single single-post postid-42389 single-format-standard wp-embed-responsive content-center">

	<div id="page" class="hfeed site">

		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		
		<header id="masthead" class="site-header clearfix" role="banner">

			<div class="header-main container clearfix">

				<div id="logo" class="site-branding clearfix">

										
			<p class="site-title"><a href="https://www.linuxlinks.com/" rel="home">LinuxLinks</a></p>

							
			<p class="site-description">The Linux Portal Site</p>

		
				</div><!-- .site-branding -->

				<div class="header-widgets clearfix">

					
				</div><!-- .header-widgets -->


			</div><!-- .header-main -->

		</header><!-- #masthead -->

		<div id="main-navigation-wrap" class="primary-navigation-wrap">

			<nav id="main-navigation" class="primary-navigation container navigation clearfix" role="navigation">
				<ul id="menu-test2" class="main-navigation-menu"><li id="menu-item-7623" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-7623"><a href="https://www.linuxlinks.com/">Home</a></li>
<li id="menu-item-2053" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2053"><a href="https://www.linuxlinks.com/linux-group-tests-part-1/">Linux Group Tests</a>
<ul class="sub-menu">
	<li id="menu-item-7634" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7634"><a href="https://www.linuxlinks.com/linux-group-tests-part-1/">Linux Group Tests – Part 1</a></li>
	<li id="menu-item-6902" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6902"><a href="https://www.linuxlinks.com/linux-group-tests-part-2/">Linux Group Tests – Part 2</a></li>
	<li id="menu-item-6903" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6903"><a href="https://www.linuxlinks.com/linux-group-tests-part-3/">Linux Group Tests – Part 3</a></li>
	<li id="menu-item-6904" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6904"><a href="https://www.linuxlinks.com/linux-group-tests-part-4/">Linux Group Tests – Part 4</a></li>
	<li id="menu-item-6905" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6905"><a href="https://www.linuxlinks.com/linux-group-tests-part-5/">Linux Group Tests – Part 5</a></li>
</ul>
</li>
<li id="menu-item-6330" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-6330"><a href="https://www.linuxlinks.com/links/">Linux Links Directory</a>
<ul class="sub-menu">
	<li id="menu-item-7559" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7559"><a href="https://www.linuxlinks.com/links/Distributions/">Distributions</a></li>
	<li id="menu-item-7560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7560"><a href="https://www.linuxlinks.com/links/Software/">Software</a></li>
	<li id="menu-item-7561" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7561"><a href="https://www.linuxlinks.com/links/UserGroups/">UserGroups</a></li>
	<li id="menu-item-7562" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7562"><a href="https://www.linuxlinks.com/links/Web/">Web Software</a></li>
	<li id="menu-item-7563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7563"><a href="https://www.linuxlinks.com/links/Java">Java</a></li>
</ul>
</li>
<li id="menu-item-31983" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31983"><a href="https://www.linuxlinks.com/category/reviews/">Reviews</a></li>
<li id="menu-item-12891" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12891"><a href="https://www.linuxlinks.com/award-winning-open-source-software/">OSS Awards</a></li>
<li id="menu-item-7639" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7639"><a href="https://www.linuxlinks.com/submit-news/">Contact Us</a></li>
</ul>			</nav><!-- #main-navigation -->

		</div>

		<div id="content-wrap" class="site-content-wrap clearfix">

			
			
			<div id="content" class="site-content container clearfix">

	<section id="primary" class="content-area">
		<main id="main" class="site-main" role="main">
				
		
<article id="post-42389" class="post-42389 post type-post status-publish format-standard has-post-thumbnail hentry category-blog category-desktop category-games tag-gaming tag-raspberry-pi tag-raspberry-pi-4">

	<img width="631" height="374" src="https://i0.wp.com/www.linuxlinks.com/wp-content/uploads/2018/06/Gaming-Chat.jpg?resize=631%2C374&amp;ssl=1" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="Gaming Chat" loading="lazy" data-lazy-src="https://i0.wp.com/www.linuxlinks.com/wp-content/uploads/2018/06/Gaming-Chat.jpg?resize=631%2C374&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />
	<header class="entry-header">

		<h1 class="entry-title">Raspberry Pi 4: Chronicling the Desktop Experience – Retro Gaming – Week 17</h1>
		<div class="entry-meta"><span class="meta-date"><a href="https://www.linuxlinks.com/raspberry-pi-4-chronicling-desktop-experience-retro-gaming/" title="7:58 am" rel="bookmark"><time class="entry-date published updated" datetime="2020-02-19T07:58:27+00:00">February 19, 2020</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://www.linuxlinks.com/author/luke-baker/" title="View all posts by Luke Baker" rel="author">Luke Baker</a></span></span><span class="meta-category"> <a href="https://www.linuxlinks.com/category/blog/" rel="category tag">Blog</a>, <a href="https://www.linuxlinks.com/category/desktop/" rel="category tag">Desktop</a>, <a href="https://www.linuxlinks.com/category/games/" rel="category tag">Games</a></span></div>
	</header><!-- .entry-header -->

	<div class="entry-content clearfix">

		<p>This is a weekly blog about the Raspberry Pi 4 (“RPI4”), the latest product in the popular Raspberry Pi range of computers.</p>
<p>I started my adventures with gaming in <strong><a href="/raspberry-pi-4-chronicling-desktop-experience-emulate-home-computers/">Week 15 of this blog</a></strong> where I evaluated home computer emulators. For this week, I&#8217;m going to look at a few retro games, all nestling in Raspbian&#8217;s repositories.  While its quad-core BCM2711 system-on-chip has more powerful processing cores, and the first upgrade to the graphics processor in the project&#8217;s history, it&#8217;s important to be realistic with expectations about the RPI4&#8217;s gaming potential.</p>
<p>Let&#8217;s kick off with a classic open source game.</p>
<!-- WP QUADS Content Ad Plugin v. 2.0.10.2 -->
<div class="quads-location quads-ad2" id="quads-ad2" style="float:none;margin:-2px 0 -2px 0;text-align:center;">
<ins class="adsbygoogle"
   style="display:inline-block;min-width:300px;max-width:970px;width:100%;height:90px"
   data-ad-client="pub-6097899789476875"
   data-ad-slot="8494081652"></ins>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>

<h4>Blob Wars: Metal Blob Solid</h4>
<figure id="attachment_42394" aria-describedby="caption-attachment-42394" style="width: 350px" class="wp-caption alignleft"><a href="/wp-content/uploads/2020/02/RPI4-Blob-Wars.png"><img loading="lazy" class="wp-image-42394 jetpack-lazy-image" src="/wp-content/uploads/2020/02/RPI4-Blob-Wars.png" alt="Raspberry Pi 4 - Blob Wars" width="350" height="270" data-lazy-srcset="https://i2.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Blob-Wars.png?w=1282&amp;ssl=1 1282w, https://i2.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Blob-Wars.png?resize=768%2C593&amp;ssl=1 768w" data-lazy-sizes="(max-width: 350px) 100vw, 350px" data-lazy-src="/wp-content/uploads/2020/02/RPI4-Blob-Wars.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="wp-image-42394" src="/wp-content/uploads/2020/02/RPI4-Blob-Wars.png" alt="Raspberry Pi 4 - Blob Wars" width="350" height="270" srcset="https://i2.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Blob-Wars.png?w=1282&amp;ssl=1 1282w, https://i2.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Blob-Wars.png?resize=768%2C593&amp;ssl=1 768w" sizes="(max-width: 350px) 100vw, 350px" /></noscript></a><figcaption id="caption-attachment-42394" class="wp-caption-text">Click for full size image</figcaption></figure>
<p>Blob Wars is a 2D platform game, where you take on the role of a fearless Blob agent, Bob, who&#8217;s mission is to infiltrate various enemy bases and rescue as many MIAs as possible, while battling many vicious aliens.</p>
<p>The game is cleverly designed, challenging, and sports some fun missions. It&#8217;s a good game with reasonable longevity. And the RPI4 handles it with aplomb.</p>
<p>A definite success.</p>
<hr />
<h4>Battle Tanks</h4>
<figure id="attachment_42402" aria-describedby="caption-attachment-42402" style="width: 350px" class="wp-caption alignright"><a href="/wp-content/uploads/2020/02/RPI4-Battle-Tanks.png"><img loading="lazy" class="wp-image-42402 jetpack-lazy-image" src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Battle-Tanks.png?resize=350%2C275&#038;ssl=1" alt="Raspberry Pi 4 - Battle Tanks" width="350" height="275" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Battle-Tanks.png?w=802&amp;ssl=1 802w, https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Battle-Tanks.png?resize=768%2C603&amp;ssl=1 768w" data-lazy-sizes="(max-width: 350px) 100vw, 350px" data-lazy-src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Battle-Tanks.png?resize=350%2C275&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="wp-image-42402" src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Battle-Tanks.png?resize=350%2C275&#038;ssl=1" alt="Raspberry Pi 4 - Battle Tanks" width="350" height="275" srcset="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Battle-Tanks.png?w=802&amp;ssl=1 802w, https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Battle-Tanks.png?resize=768%2C603&amp;ssl=1 768w" sizes="(max-width: 350px) 100vw, 350px" data-recalc-dims="1" /></noscript></a><figcaption id="caption-attachment-42402" class="wp-caption-text">Click for full size image</figcaption></figure>
<p>Battle Tanks is an amusing battle on your desk, where you can choose one of three vehicles and eliminate your enemy using the whole arsenal of weapons. It has original cartoon-like graphics and cool music.</p>
<p>I remember trying this game on an earlier model of the Raspberry Pi. I can&#8217;t remember if it was the Pi 2 or the Pi 3. But I do recall I wasn&#8217;t happy with the performance. It ran like a turkey. With the RPI4, it&#8217;s a whole new ball game [Ed &#8211; that&#8217;s a different type of game].</p>
<p>The game runs really well on the RPI4. Hours of fun.</p>
<hr />
<h4>OpenArena</h4>
<figure id="attachment_42422" aria-describedby="caption-attachment-42422" style="width: 350px" class="wp-caption alignleft"><a href="/wp-content/uploads/2020/02/RPI4-OpenArena.png"><img loading="lazy" class="wp-image-42422 jetpack-lazy-image" src="https://i0.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-OpenArena.png?resize=350%2C278&#038;ssl=1" alt="Raspberry Pi 4 - OpenArena" width="350" height="278" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-OpenArena.png?resize=350%2C278&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="wp-image-42422" src="https://i0.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-OpenArena.png?resize=350%2C278&#038;ssl=1" alt="Raspberry Pi 4 - OpenArena" width="350" height="278" data-recalc-dims="1" /></noscript></a><figcaption id="caption-attachment-42422" class="wp-caption-text">Click for full size image</figcaption></figure>
<p>OpenArena aims to be a free, yet compatible clone of Quake III Arena, a multi-player first person shooter. OpenArena is free and open source. And it&#8217;s included in the Raspbian repositories together with lots of game data such as maps, player graphics, and textures. Install OpenArena with PiPackages or from the command line, and all the game data packages, community map packs etc. are installed automatically.</p>
<p>While RPI4 offers much better performance compared to its predecessors, don&#8217;t think you can run OpenArena at high resolutions. To get high frame rates it&#8217;s still necessary to turn down the graphics settings. For example, I turned the GL Extensions off, set Geometric detail to low, and the Texture detail to low. And I used a low resolution. With these settings I can get 70-100 fps a second. Very smooth graphics at the expense of some of the intrinsic beauty. And there&#8217;s still occasional glitches and/or tearing evident which is disappointing.</p>
<hr />
<h4>Doom</h4>
<figure id="attachment_42411" aria-describedby="caption-attachment-42411" style="width: 350px" class="wp-caption alignright"><a href="/wp-content/uploads/2020/02/RPI4-Doom.png"><img loading="lazy" class="wp-image-42411 jetpack-lazy-image" src="https://i2.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Doom.png?resize=350%2C231&#038;ssl=1" alt="Raspberry Pi 4 - Doom" width="350" height="231" data-recalc-dims="1" data-lazy-srcset="https://i2.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Doom.png?w=802&amp;ssl=1 802w, https://i2.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Doom.png?resize=768%2C508&amp;ssl=1 768w" data-lazy-sizes="(max-width: 350px) 100vw, 350px" data-lazy-src="https://i2.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Doom.png?resize=350%2C231&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="wp-image-42411" src="https://i2.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Doom.png?resize=350%2C231&#038;ssl=1" alt="Raspberry Pi 4 - Doom" width="350" height="231" srcset="https://i2.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Doom.png?w=802&amp;ssl=1 802w, https://i2.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Doom.png?resize=768%2C508&amp;ssl=1 768w" sizes="(max-width: 350px) 100vw, 350px" data-recalc-dims="1" /></noscript></a><figcaption id="caption-attachment-42411" class="wp-caption-text">Click for full size image</figcaption></figure>
<p>Chocolate Doom aims to accurately reproduce the original DOS version of Doom and other games based on the Doom engine in a form that can be run on modern computers.  Installing the Raspbian package adds menu entries for Doom, Heretic, Hexen, and Strife.</p>
<p>While there&#8217;s the convenient package in the Raspbian repositories, you&#8217;ll need a DOOM wad to play the game. See the end of the article for the commands to grab one.</p>
<p>Now, we&#8217;ve strayed away from open source, as the WAD file is shareware. I focused on Doom for this week, and was pleased with the performance. Even though I&#8217;ve played the game on and off for years, it&#8217;s still enjoyable.</p>
<hr />
<h4>Beneath a Steel Sky</h4>
<figure id="attachment_42409" aria-describedby="caption-attachment-42409" style="width: 350px" class="wp-caption alignleft"><a href="/wp-content/uploads/2020/02/RPI4-Beneath-Steel-Sky.png"><img loading="lazy" class="wp-image-42409 jetpack-lazy-image" src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Beneath-Steel-Sky.png?resize=350%2C234&#038;ssl=1" alt="Raspberry Pi 4 - Beneath a Steel Sky" width="350" height="234" data-recalc-dims="1" data-lazy-srcset="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Beneath-Steel-Sky.png?w=642&amp;ssl=1 642w, https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Beneath-Steel-Sky.png?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Beneath-Steel-Sky.png?resize=420%2C280&amp;ssl=1 420w" data-lazy-sizes="(max-width: 350px) 100vw, 350px" data-lazy-src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Beneath-Steel-Sky.png?resize=350%2C234&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="wp-image-42409" src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Beneath-Steel-Sky.png?resize=350%2C234&#038;ssl=1" alt="Raspberry Pi 4 - Beneath a Steel Sky" width="350" height="234" srcset="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Beneath-Steel-Sky.png?w=642&amp;ssl=1 642w, https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Beneath-Steel-Sky.png?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/02/RPI4-Beneath-Steel-Sky.png?resize=420%2C280&amp;ssl=1 420w" sizes="(max-width: 350px) 100vw, 350px" data-recalc-dims="1" /></noscript></a><figcaption id="caption-attachment-42409" class="wp-caption-text">Click for full size image</figcaption></figure>
<p>Set in a futuristic Australian dystopian future (like Mad Max but with cities), Beneath a Steel Sky is a point-and-click adventure. While rare these days, back in the 1990s they were a popular approach to the story-focused adventure game.</p>
<p>The game runs well on the RPI4, but it&#8217;s the least demanding of the games I&#8217;m covering here, so that&#8217;s unsurprising. If you like point-and-click adventures, it&#8217;s a good introduction.</p>
<p>Beneath a Steel Sky runs on modern computers thanks to ScummVM, a virtual machine for several classic graphical point-and-click adventure games.</p>
<hr />
<h4>Summary</h4>
<p>This is just a taster to native gaming on the RPI4. Most of the games ran well without any tweaking, although turning down a few of the graphics options in OpenArena helped a great deal.</p>
<p>There&#8217;s a good range of open source games available for the RPI4, covering all game genres. Lots to explore.</p>
<p>You might be wondering about Steam on the RPI4. Well it isn&#8217;t available. The only crumb of comfort is Steam Link is available [it&#8217;s in the Raspbian repositories]. Steam Link is a program that lets you pair a controller to your RPI4, connect to a computer running Steam on the same local network, and start playing your existing Steam games. That doesn&#8217;t really make the RPI4 a desktop replacement. But it lets you stream video games from a PC to a display of choice. If there&#8217;s demand, I&#8217;ll take a look at Steam Link in a later edition of the blog.</p>
<hr />
<p>You can download game files for Doom. For example, to get the shareware DOOM1.wad file, enter:</p>
<div class="box-grey">
$ wget https://www.doomworld.com/3ddownloads/ports/shareware_doom_iwad.zip<br />
$ unzip shareware_doom-iwad.zip<br />
$ sudo mv DOOM1.WAD /usr/games/
</div>
<hr />
<p>Read all my blog posts about the RPI4.</p>

<table id="tablepress-566" class="tablepress tablepress-id-566">
<thead>
<tr class="row-1">
	<th colspan="2" class="column-1"><strong>Raspberry Pi 4 Blog</strong></th>
</tr>
</thead>
<tbody>
<tr class="row-2">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-manage-personal-collections/">Week 36</a></strong></td><td class="column-2">Manage your personal collections on the RPI4</td>
</tr>
<tr class="row-3">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-terminal-emulators/">Week 35</a></strong></td><td class="column-2">Survey of terminal emulators</td>
</tr>
<tr class="row-4">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-desktop-searching/">Week 34</a></strong></td><td class="column-2">Search the desktop with the latest version of Recoll</td>
</tr>
<tr class="row-5">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-personal-information-managers/">Week 33</a></strong></td><td class="column-2">Personal Information Managers on the RPI4</td>
</tr>
<tr class="row-6">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-dear-diary/">Week 32</a></strong></td><td class="column-2">Keep a diary with the RPI4</td>
</tr>
<tr class="row-7">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-calculators/">Week 31</a></strong></td><td class="column-2">Process complex mathematical functions, plot 2D and 3D graphs with calculators</td>
</tr>
<tr class="row-8">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-streaming-radio/">Week 30</a></strong></td><td class="column-2">Internet radio on this tiny computer. A detailed survey of open source software</td>
</tr>
<tr class="row-9">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-professionally-manage-photo-collection/">Week 29</a></strong></td><td class="column-2">Professionally manage your photo collection with digiKam</td>
</tr>
<tr class="row-10">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-typeset-beautifully-lyx/">Week 28</a></strong></td><td class="column-2">Typeset beautifully with LyX</td>
</tr>
<tr class="row-11">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-learning-computers-kids/">Week 27</a></strong></td><td class="column-2">Software that teaches young people how to learn basic computing skills and beyond</td>
</tr>
<tr class="row-12">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-firefox-revisited/">Week 26</a></strong></td><td class="column-2">Firefox revisited - Raspbian now offers a real alternative to Chromium</td>
</tr>
<tr class="row-13">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-taking-notes/">Week 25</a></strong></td><td class="column-2">Turn the Raspberry Pi 4 into a low power writing machine</td>
</tr>
<tr class="row-14">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-educational-games-kids/">Week 24</a></strong></td><td class="column-2">Keep the kids learning and having fun</td>
</tr>
<tr class="row-15">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-viewing-photos/">Week 23</a></strong></td><td class="column-2">Lots of choices to view images</td>
</tr>
<tr class="row-16">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-podcasts/">Week 22</a></strong></td><td class="column-2">Listening to podcasts on the RPI4</td>
</tr>
<tr class="row-17">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-file-management/">Week 21</a></strong></td><td class="column-2">File management on the RPI4</td>
</tr>
<tr class="row-18">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-obs-studio/">Week 20</a></strong></td><td class="column-2">Open Broadcaster Software (OBS Studio) on the RPI4</td>
</tr>
<tr class="row-19">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-news/">Week 19</a></strong></td><td class="column-2">Keep up-to-date with these news aggregators</td>
</tr>
<tr class="row-20">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-firefox-upgrade/">Week 18</a></strong></td><td class="column-2">Web Browsers Again: Firefox</td>
</tr>
<tr class="row-21">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-retro-gaming/">Week 17</a></strong></td><td class="column-2">Retro gaming on the RPI4</td>
</tr>
<tr class="row-22">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-screen-capture/">Week 16</a></strong></td><td class="column-2">Screen capturing with the RPI4</td>
</tr>
<tr class="row-23">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-emulate-home-computers/">Week 15</a></strong></td><td class="column-2">Emulate the Amiga, ZX Spectrum, and the Atari ST on the RPI4</td>
</tr>
<tr class="row-24">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-the-desktop-experience-memory-usage/">Week 14</a></strong></td><td class="column-2">Choose the right model of the RPI4 for your desktop needs</td>
</tr>
<tr class="row-25">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-screen-recording/">Week 13</a></strong></td><td class="column-2">Using the RPI4 as a screencaster</td>
</tr>
<tr class="row-26">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-reading-comics/">Week 12</a></strong></td><td class="column-2">Have fun reading comics on the RPI4 with YACReader, MComix, and  more</td>
</tr>
<tr class="row-27">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-the-desktop-experience-home-theater/">Week 11</a></strong></td><td class="column-2">Turn the RPI4 into a complete home theater</td>
</tr>
<tr class="row-28">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-the-desktop-experience-watching-video/">Week 10</a></strong></td><td class="column-2">Watching locally stored video with VLC, OMXPlayer, and others</td>
</tr>
<tr class="row-29">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-viewing-pdf/">Week 9</a></strong></td><td class="column-2">PDF viewing on the RPI4</td>
</tr>
<tr class="row-30">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-remote-desktop/">Week 8</a></strong></td><td class="column-2">Access the RPI4 remotely running GUI apps</td>
</tr>
<tr class="row-31">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-e-book-tools/">Week 7</a></strong></td><td class="column-2">e-book tools are put under the microscope</td>
</tr>
<tr class="row-32">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-office-software/">Week 6</a></strong></td><td class="column-2">The office suite is the archetypal business software. LibreOffice is tested</td>
</tr>
<tr class="row-33">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-email/">Week 5</a></strong></td><td class="column-2">Managing your email box with the RPI4</td>
</tr>
<tr class="row-34">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-web-browsing/">Week 4</a></strong></td><td class="column-2">Web surfing on the RPI4 looking at Chromium, Vivaldi, Firefox, and Midori</td>
</tr>
<tr class="row-35">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-video-playback">Week 3</a></strong></td><td class="column-2">Video streaming with Chromium &amp; omxplayerGUI as well as streamlink</td>
</tr>
<tr class="row-36">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-music-players/">Week 2</a></strong></td><td class="column-2">A survey of open source music players on the RPI4 including Tauon Music Box</td>
</tr>
<tr class="row-37">
	<td class="column-1"><strong><a href="/raspberry-pi-4-chronicling-desktop-experience-week-1/">Week 1</a></strong></td><td class="column-2">An introduction to the world of the RPI4 looking at musikcube and PiPackages</td>
</tr>
</tbody>
</table>
<!-- #tablepress-566 from cache -->
<p>This blog is written on the RPI4.
<!-- WP QUADS Content Ad Plugin v. 2.0.10.2 -->
<div class="quads-location quads-ad3" id="quads-ad3" style="float:none;margin:0px;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive - Text Only -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1180843672"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related articles</em></h3>
</div><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="addtoany_header">Share this article</div><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.linuxlinks.com/raspberry-pi-4-chronicling-desktop-experience-retro-gaming/" data-a2a-title="Raspberry Pi 4: Chronicling the Desktop Experience – Retro Gaming – Week 17"><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fraspberry-pi-4-chronicling-desktop-experience-retro-gaming%2F&amp;linkname=Raspberry%20Pi%204%3A%20Chronicling%20the%20Desktop%20Experience%20%E2%80%93%20Retro%20Gaming%20%E2%80%93%20Week%2017" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fraspberry-pi-4-chronicling-desktop-experience-retro-gaming%2F&amp;linkname=Raspberry%20Pi%204%3A%20Chronicling%20the%20Desktop%20Experience%20%E2%80%93%20Retro%20Gaming%20%E2%80%93%20Week%2017" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fraspberry-pi-4-chronicling-desktop-experience-retro-gaming%2F&amp;linkname=Raspberry%20Pi%204%3A%20Chronicling%20the%20Desktop%20Experience%20%E2%80%93%20Retro%20Gaming%20%E2%80%93%20Week%2017" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fraspberry-pi-4-chronicling-desktop-experience-retro-gaming%2F&amp;linkname=Raspberry%20Pi%204%3A%20Chronicling%20the%20Desktop%20Experience%20%E2%80%93%20Retro%20Gaming%20%E2%80%93%20Week%2017" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_linkedin" href="https://www.addtoany.com/add_to/linkedin?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fraspberry-pi-4-chronicling-desktop-experience-retro-gaming%2F&amp;linkname=Raspberry%20Pi%204%3A%20Chronicling%20the%20Desktop%20Experience%20%E2%80%93%20Retro%20Gaming%20%E2%80%93%20Week%2017" title="LinkedIn" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_mix" href="https://www.addtoany.com/add_to/mix?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fraspberry-pi-4-chronicling-desktop-experience-retro-gaming%2F&amp;linkname=Raspberry%20Pi%204%3A%20Chronicling%20the%20Desktop%20Experience%20%E2%80%93%20Retro%20Gaming%20%E2%80%93%20Week%2017" title="Mix" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fraspberry-pi-4-chronicling-desktop-experience-retro-gaming%2F&amp;linkname=Raspberry%20Pi%204%3A%20Chronicling%20the%20Desktop%20Experience%20%E2%80%93%20Retro%20Gaming%20%E2%80%93%20Week%2017" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_hacker_news" href="https://www.addtoany.com/add_to/hacker_news?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fraspberry-pi-4-chronicling-desktop-experience-retro-gaming%2F&amp;linkname=Raspberry%20Pi%204%3A%20Chronicling%20the%20Desktop%20Experience%20%E2%80%93%20Retro%20Gaming%20%E2%80%93%20Week%2017" title="Hacker News" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fraspberry-pi-4-chronicling-desktop-experience-retro-gaming%2F&amp;linkname=Raspberry%20Pi%204%3A%20Chronicling%20the%20Desktop%20Experience%20%E2%80%93%20Retro%20Gaming%20%E2%80%93%20Week%2017" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>
		
	</div><!-- .entry-content -->

	<footer class="entry-footer">

		
			<div class="entry-tags clearfix">
				<span class="meta-tags">
					<a href="https://www.linuxlinks.com/tag/gaming/" rel="tag">gaming</a><a href="https://www.linuxlinks.com/tag/raspberry-pi/" rel="tag">Raspberry Pi</a><a href="https://www.linuxlinks.com/tag/raspberry-pi-4/" rel="tag">Raspberry Pi 4</a>				</span>
			</div><!-- .entry-tags -->

				
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.linuxlinks.com/excellent-free-tutorials-learn-haskell/" rel="prev"><span class="screen-reader-text">Previous Post:</span>Excellent Free Tutorials to Learn Haskell</a></div><div class="nav-next"><a href="https://www.linuxlinks.com/excellent-free-tutorials-learn-scheme/" rel="next"><span class="screen-reader-text">Next Post:</span>Excellent Free Tutorials to Learn Scheme</a></div></div>
	</nav>
	</footer><!-- .entry-footer -->

</article>

<div id="comments" class="comments-area">

	
	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Share your Thoughts					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/raspberry-pi-4-chronicling-desktop-experience-retro-gaming/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=139785133&#038;postid=42389&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Share+your+Thoughts&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=transparent&#038;lang=en_GB&#038;jetpack_version=8.8.2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=5155866744f34b37f8e755a56f8c0db514b1277f#parent=https%3A%2F%2Fwww.linuxlinks.com%2Fraspberry-pi-4-chronicling-desktop-experience-retro-gaming%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = true;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments -->
		
		</main><!-- #main -->
	</section><!-- #primary -->
	
		<section id="secondary" class="main-sidebar widget-area clearfix" role="complementary">

		
<!-- Quick Adsense Reloaded -->
<aside id="adswidget1-quick-adsense-reloaded-4" class="widget quads-ad1_widget clearfix"><div id="quads-ad1_widget" style="margin:0px 0px 0px 0px; padding:0px 0px 0px 0px; "><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Response -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1669640918"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center></div></aside>
		<aside id="recent-posts-2" class="widget widget_recent_entries clearfix">
		<div class="widget-header"><h3 class="widget-title">Recent Posts</h3></div>
		<ul>
											<li>
					<a href="https://www.linuxlinks.com/contributing-open-source-projects/">Contributing to Open Source Projects without Coding Knowledge</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/linux-candy-bash-pipes-animated-pipes-terminal-screensaver/">Linux Candy: pipes.sh &#8211; animated pipes terminal screensaver</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/best-free-configuration-frameworks-emacs/">5 Best Free Configuration Frameworks for Emacs</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/awow-ak41-mini-desktop-pc-home-computer-emulators/">AWOW AK41 Mini Desktop PC &#8211; Home Computer Emulators &#8211; Week 7</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/excellent-free-tutorials-learn-kotlin/">Excellent Free Tutorials to Learn Kotlin</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/vooki-lightweight-image-viewer-fast-image-preview/">Vooki &#8211; lightweight image viewer offering fast image preview</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/best-free-vim-like-text-editors/">8 Best Free Vim-Like Text Editors</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/cointop-monitor-cryptocurrencies-terminal/">cointop &#8211; monitor cryptocurrencies in the terminal</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/best-emacs-like-text-editors/">7 Best Emacs-Like Text Editors</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/awow-ak41-mini-desktop-pc-web-browsing/">AWOW AK41 Mini Desktop PC &#8211; Web Browsing &#8211; Week 6</a>
									</li>
					</ul>

		</aside><aside id="jetpack-search-filters-6" class="widget jetpack-filters widget_search clearfix">			<div id="jetpack-search-filters-6-wrapper" >
		<div class="jetpack-search-form">
<form role="search" method="get" class="search-form" action="https://www.linuxlinks.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field"
			placeholder="Search &hellip;"
			value="" name="s"
			title="Search for:" />
	</label>
	<button type="submit" class="search-submit">
		<span class="genericon-search"></span>
		<span class="screen-reader-text">Search</span>
	</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /></form>
</div></div></aside><aside id="recent-comments-2" class="widget widget_recent_comments clearfix"><div class="widget-header"><h3 class="widget-title">Recent Comments</h3></div><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Kevin J</span> on <a href="https://www.linuxlinks.com/contributing-open-source-projects/#comment-1201">Contributing to Open Source Projects without Coding Knowledge</a></li><li class="recentcomments"><span class="comment-author-link">Raul</span> on <a href="https://www.linuxlinks.com/dictionarytools/#comment-1200">6 Best Free Linux Dictionary Tools</a></li><li class="recentcomments"><span class="comment-author-link">Steve Emms</span> on <a href="https://www.linuxlinks.com/best-emacs-like-text-editors/#comment-1199">7 Best Emacs-Like Text Editors</a></li><li class="recentcomments"><span class="comment-author-link">David Harper</span> on <a href="https://www.linuxlinks.com/awow-ak41-mini-desktop-pc-home-computer-emulators/#comment-1198">AWOW AK41 Mini Desktop PC &#8211; Home Computer Emulators &#8211; Week 7</a></li><li class="recentcomments"><span class="comment-author-link">Steve Emms</span> on <a href="https://www.linuxlinks.com/best-free-neovim-guis/#comment-1194">10 Best Free Neovim GUIs</a></li></ul></aside>
<!-- Quick Adsense Reloaded -->
<aside id="adswidget1-quick-adsense-reloaded-9" class="widget quads-ad1_widget clearfix"><div id="quads-ad1_widget" style="margin:0px 0px 0px 0px; padding:0px 0px 0px 0px; "><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Response -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1669640918"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center></div></aside><aside id="text-12" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Programming Books</h3></div>			<div class="textwidget"><div class="box-grey">Read our <strong><a href="/excellent-free-programming-books/">curated lists of great free programming books</a></strong> for whatever language takes your fancy!</p>
<p>Alternatively, check out our series of <strong><a href="/category/tutorials/">great free programming tutorials</a></strong>.
</div>
</div>
		</aside><aside id="text-7" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Group Tests</h3></div>			<div class="textwidget"><div class="box-grey"><strong><a href="/ProjectManagement/">12 Project Management</a></strong><br />
<strong><a href="/linux-means-business-best-free-business-apps/">42 Business Apps</a></strong><br />
<strong><a href="/linux-education-best-free-apps/">42 Education Apps</a></strong><br />
<strong><a href="/excellent-free-linux-relational-databases/">10 Databases</a></strong><br />
<strong><a href="/backup/">31 Backup Tools</a></strong><br />
<strong><a href="/ProductivityTools/">21 Productivity Tools</a></strong><br />
<strong><a href="/TerminalEmulators/">22 Terminal Emulators</a></strong><br />
<strong><a href="/best-free-linux-financial-software/">21 Financial Tools</a></strong><br />
<strong><a href="/BitcoinClients/">3 Bitcoin Clients</a></strong><br />
<strong><a href="/TextEditors/">21 Text Editors</a></strong><br />
<a href="/GraphicsSoftware/"><strong>42 Graphics Apps</strong></a><br />
<strong><a href="/EmailApps/">42 Email Apps</a></strong><br />
<strong><a href="/VoIP/">13 VoIP Apps</a></strong><br />
<strong><a href="/Games/">42 Best Games</a></strong><br />
<strong><a href="/Video/">42 Video Apps</a></strong></div>
</div>
		</aside><aside id="archives-6" class="widget widget_archive clearfix"><div class="widget-header"><h3 class="widget-title">Archives</h3></div>		<label class="screen-reader-text" for="archives-dropdown-6">Archives</label>
		<select id="archives-dropdown-6" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://www.linuxlinks.com/2020/08/'> August 2020 </option>
	<option value='https://www.linuxlinks.com/2020/07/'> July 2020 </option>
	<option value='https://www.linuxlinks.com/2020/06/'> June 2020 </option>
	<option value='https://www.linuxlinks.com/2020/05/'> May 2020 </option>
	<option value='https://www.linuxlinks.com/2020/04/'> April 2020 </option>
	<option value='https://www.linuxlinks.com/2020/03/'> March 2020 </option>
	<option value='https://www.linuxlinks.com/2020/02/'> February 2020 </option>
	<option value='https://www.linuxlinks.com/2020/01/'> January 2020 </option>
	<option value='https://www.linuxlinks.com/2019/12/'> December 2019 </option>
	<option value='https://www.linuxlinks.com/2019/11/'> November 2019 </option>
	<option value='https://www.linuxlinks.com/2019/10/'> October 2019 </option>
	<option value='https://www.linuxlinks.com/2019/09/'> September 2019 </option>
	<option value='https://www.linuxlinks.com/2019/08/'> August 2019 </option>
	<option value='https://www.linuxlinks.com/2019/07/'> July 2019 </option>
	<option value='https://www.linuxlinks.com/2019/06/'> June 2019 </option>
	<option value='https://www.linuxlinks.com/2019/05/'> May 2019 </option>
	<option value='https://www.linuxlinks.com/2019/04/'> April 2019 </option>
	<option value='https://www.linuxlinks.com/2019/03/'> March 2019 </option>
	<option value='https://www.linuxlinks.com/2019/02/'> February 2019 </option>
	<option value='https://www.linuxlinks.com/2019/01/'> January 2019 </option>
	<option value='https://www.linuxlinks.com/2018/12/'> December 2018 </option>
	<option value='https://www.linuxlinks.com/2018/11/'> November 2018 </option>
	<option value='https://www.linuxlinks.com/2018/10/'> October 2018 </option>
	<option value='https://www.linuxlinks.com/2018/09/'> September 2018 </option>
	<option value='https://www.linuxlinks.com/2018/08/'> August 2018 </option>
	<option value='https://www.linuxlinks.com/2018/07/'> July 2018 </option>
	<option value='https://www.linuxlinks.com/2018/06/'> June 2018 </option>
	<option value='https://www.linuxlinks.com/2018/05/'> May 2018 </option>
	<option value='https://www.linuxlinks.com/2018/04/'> April 2018 </option>
	<option value='https://www.linuxlinks.com/2018/03/'> March 2018 </option>
	<option value='https://www.linuxlinks.com/2018/02/'> February 2018 </option>
	<option value='https://www.linuxlinks.com/2018/01/'> January 2018 </option>
	<option value='https://www.linuxlinks.com/2017/12/'> December 2017 </option>
	<option value='https://www.linuxlinks.com/2017/11/'> November 2017 </option>
	<option value='https://www.linuxlinks.com/2017/10/'> October 2017 </option>
	<option value='https://www.linuxlinks.com/2017/09/'> September 2017 </option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-6" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</aside>
	</section><!-- #secondary -->
	<section id="secondary" class="small-sidebar widget-area clearfix" role="complementary">

		<aside id="text-15" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Get Involved</h3></div>			<div class="textwidget"><div class="box-grey"><a href="/sponsor-donate-linuxlinks/"><strong>Donate</strong></a> to LinuxLinks. Your help is appreciated.</p>
<p><strong><a href="/sponsor-donate-linuxlinks/">Sponsorship opportunities</a></strong> &#8211; Have a product or service you wish to promote?
</div>
</div>
		</aside>
<!-- Quick Adsense Reloaded -->
<aside id="adswidget1-quick-adsense-reloaded-8" class="widget quads-ad1_widget clearfix"><div id="quads-ad1_widget" style="margin:0px 0px 0px 0px; padding:0px 0px 0px 0px; "><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Response -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1669640918"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center></div></aside><aside id="text-13" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Luke&#8217;s Weekly Blog</h3></div>			<div class="textwidget"><div class="box-grey">
<p>Luke is currently writing his weekly blog about the <strong><a href="/category/blog/">AWOW AK41 Mini Desktop PC</a></strong>.</p>
<p>Other hardware: <strong><a href="/tag/raspberry-pi-4/">Raspberry Pi 4 single board computer</a></strong></p>
</div>
</div>
		</aside><aside id="text-14" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Data Science</h3></div>			<div class="textwidget"><div class="box-grey">
<p>Take our free interactive courses in data science. There&#8217;s our course for <strong><a href="/python-data-science/">Python using pandas and plotnine</a></strong>, and our course for <strong><a href="/r-rstudio-data-science/">R using ggplot2</a></strong>. </p>
<p>Get up to speed in 20 minutes. No programming knowledge required.</p>
</div>
</div>
		</aside><aside id="text-11" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Reviews</h3></div>			<div class="textwidget"><div class="box-grey">We&#8217;ve written tons of in-depth and <span data-dobid="hdw">completely</span> impartial reviews of open source software. <strong><a href="/category/reviews/">Read our reviews</a></strong>.
</div>
</div>
		</aside><aside id="text-9" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Desktops</h3></div>			<div class="textwidget"><div class="box-grey"><strong><a href="/survey-linux-desktop-environments/">9 Best Desktops</a></strong><br />
<strong><a href="/excellent-kde-plasma-widgets/">24 KDE Widgets</a></strong><br />
<strong><a href="/excellent-gnome-desktop-extensions/">33 GNOME Extensions</a></strong><br />
<strong><a href="/linux-desktop-environments-pantheon-trinity-lxde/">Pantheon, Trinity, LXDE</a></strong></div>
</div>
		</aside><aside id="text-10" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">System Tools</h3></div>			<div class="textwidget"><div class="box-grey">Manage your system with <strong><a href="/essential-system-tools-excellent-ways-manage-system/">25 essential system tools</a></strong>. We&#8217;ve written an in-depth review for each of them.</p>
<p>We&#8217;re also writing a series of reviews showcasing <strong><a href="/outstanding-linux-utilities-maximize-productivity/">excellent utilities</a></strong>.
</div>
</div>
		</aside><aside id="eu_cookie_law_widget-3" class="widget widget_eu_cookie_law_widget clearfix"><div
	class="hide-on-button"
	data-hide-timeout="30"
	data-consent-expiration="180"
	id="eu-cookie-law"
>
	<form method="post">
		<input type="submit" value="Close and accept" class="accept" />
	</form>

	Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
	<a href="https://www.linuxlinks.com/privacy-policy/" >
		Cookie Policy	</a>
</div>
</aside><aside id="meta-2" class="widget widget_meta clearfix"><div class="widget-header"><h3 class="widget-title">Meta</h3></div>
		<ul>
						<li><a rel="nofollow" href="https://www.linuxlinks.com/wp-login.php">Log in</a></li>
			<li><a href="https://www.linuxlinks.com/feed/">Entries feed</a></li>
			<li><a href="https://www.linuxlinks.com/comments/feed/">Comments feed</a></li>

			<li><a href="https://en-gb.wordpress.org/">WordPress.org</a></li>
		</ul>

		</aside><aside id="text-8" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Related</h3></div>			<div class="textwidget"><p><a href="/link-us/">Link us</a><br />
<a href="/faq/">FAQ</a><br />
<a href="https://www.forfoss.com/">ForFOSS.com</a><br />
<a href="https://www.ossblog.org/">OSSBlog.org</a><br />
<a href="/privacy-policy/">Privacy Policy</a></p>
</div>
		</aside>
	</section><!-- #secondary -->
	

		</div><!-- #content -->

	</div><!-- #content-wrap -->

	
	<div id="footer" class="site-footer-wrap">

		<footer id="colophon" class="site-footer container clearfix" role="contentinfo">

			<div id="footer-text" class="site-info">
				
	<span class="credit-link">
		Copyright 2018-2020 LinuxLinks.com	</span>

				</div><!-- .site-info -->

			
		</footer><!-- #colophon -->

	</div>

</div><!-- #page -->

<script type="text/javascript">
   if(typeof quadsOptions !== 'undefined' && typeof wpquads_adblocker_check_2 
  === 'undefined' && quadsOptions.quadsChoice == 'ad_blocker_message'){

  var addEvent1 = function (obj, type, fn) {
      if (obj.addEventListener)
          obj.addEventListener(type, fn, false);
      else if (obj.attachEvent)
          obj.attachEvent('on' + type, function () {
              return fn.call(obj, window.event);
          });
  };
   addEvent1(window, 'load', function () {
      if (typeof wpquads_adblocker_check_2 === "undefined" || wpquads_adblocker_check_2 === false) {
          highlight_adblocked_ads();
      }
  });

   function highlight_adblocked_ads() {
      try {
          var ad_wrappers = document.querySelectorAll('div[id^="quads-ad"]')
      } catch (e) {
          return;
      }

      for (i = 0; i < ad_wrappers.length; i++) {
          ad_wrappers[i].className += ' quads-highlight-adblocked';
          ad_wrappers[i].className = ad_wrappers[i].className.replace('quads-location', '');
          ad_wrappers[i].setAttribute('style', 'display:block !important');
      }
  }
 }

(function() {
//Adblocker Notice Script Starts Here
var curr_url = window.location.href;
var red_ulr = localStorage.getItem('curr');
var modal = document.getElementById("quads-myModal");
var quadsAllowedCookie =  quadsgetCookie('quadsAllowedCookie');

if(typeof quadsOptions !== 'undefined' && typeof wpquads_adblocker_check_2 
  === 'undefined' ){

  if(quadsAllowedCookie!=quadsOptions.allow_cookies){
    quadssetCookie('quadsCookie', '', -1, '/');
    quadssetCookie('quadsAllowedCookie', quadsOptions.allow_cookies, 1, '/');
  }

  if(quadsOptions.allow_cookies == 2){
    if( quadsOptions.quadsChoice == 'bar' || quadsOptions.quadsChoice == 'popup'){
        modal.style.display = "block";
        quadssetCookie('quadsCookie', '', -1, '/');
    }
    
    if(quadsOptions.quadsChoice == 'page_redirect' && quadsOptions.page_redirect !="undefined"){
        if(red_ulr==null || curr_url!=quadsOptions.page_redirect){
        window.location = quadsOptions.page_redirect;
        localStorage.setItem('curr',quadsOptions.page_redirect);
      }
    }
  }else{
    var adsCookie = quadsgetCookie('quadsCookie');
    if(adsCookie==false) {
      if( quadsOptions.quadsChoice == 'bar' || quadsOptions.quadsChoice == 'popup'){
          modal.style.display = "block";
      }
      if(quadsOptions.quadsChoice == 'page_redirect' && quadsOptions.page_redirect !="undefined"){
        window.location = quadsOptions.page_redirect;
        quadssetCookie('quadsCookie', true, 1, '/');
      }
    }else{
      modal.style.display = "none";
    }
  }
}

function quadsgetCookie(cname){
    var name = cname + '=';
    var ca = document.cookie.split(';');
    for (var i = 0; i < ca.length; i++) {
        var c = ca[i].trim();
        if (c.indexOf(name) === 0) {
            return c.substring(name.length, c.length);
        }
    }
    return false;
}
function quadssetCookie(cname, cvalue, exdays, path){
  var d = new Date();
  d.setTime(d.getTime() + (exdays*24*60*60*1000));
  var expires = "expires="+ d.toUTCString();
  document.cookie = cname + "=" + cvalue + ";" + expires + ";path=/";
}

var span = document.getElementsByClassName("quads-cls-notice")[0];
if(span){
  span.onclick = function() {
    modal.style.display = "none";
    document.cookie = "quads_prompt_close="+new Date();
    quadssetCookie('quadsCookie', 'true', 1, '/');
  }
}

window.onclick = function(event) {
  if (event.target == modal) {
    modal.style.display = "none";
    document.cookie = "quads_prompt_close="+new Date();
    quadssetCookie('quadsCookie', 'true', 1, '/');
  }
}
})();
//Adblocker Notice Script Ends Here
</script>

<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.8.2/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.8.2/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js' id='eu-cookie-law-script-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.8.2/modules/widgets/search/js/search-widget.js' id='jetpack-search-widget-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.8.2/_inc/build/lazy-images/js/lazy-images.min.js' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://www.linuxlinks.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6' id='akismet-form-js'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=139785133&postid=42389&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=identicon&greeting=Share+your+Thoughts&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_GB&jetpack_version=8.8.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=5155866744f34b37f8e755a56f8c0db514b1277f#parent=https%3A%2F%2Fwww.linuxlinks.com%2Fraspberry-pi-4-chronicling-desktop-experience-retro-gaming%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=139785133&postid=42389&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=identicon&greeting=Share+your+Thoughts&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_GB&jetpack_version=8.8.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=5155866744f34b37f8e755a56f8c0db514b1277f#parent=https%3A%2F%2Fwww.linuxlinks.com%2Fraspberry-pi-4-chronicling-desktop-experience-retro-gaming%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202034.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.8.2',blog:'139785133',post:'42389',tz:'1',srv:'www.linuxlinks.com'} ]);
	_stq.push([ 'clickTrackerInit', '139785133', '42389' ]);
</script>

</body>
</html>

<!-- Cached by WP-Optimize (gzip) - https://getwpo.com - Last modified: Sat, 22 Aug 2020 20:32:21 GMT -->
