quark is an extremely small and simple HTTP GET/HEAD-only web server for static content.
The goal of this project is to do one thing and do it well, namely serving static web directories and doing that right.
This is free and open source software.
Key Features
- Supports virtual hosts.
- Supports explicit redirects.
- Supports directory listings.
- Supports conditional “If-Modified-Since”-requests (RFC 7232)
- Supports range requests (RFC 7233)
- Supports well-known URIs (RFC 8615)
- Refuses to serve hidden files and directories.
Website: tools.suckless.org/quark
Support:
Developer: Laslo Hunhold
License: ISC License
quark is written in C. Learn C with our recommended free books and free tutorials.
Related Software
| Static Web Servers | |
|---|---|
| miniserve | CLI tool to serve files and dirs over HTTP |
| serve | Static file serving and directory listing |
| binserve | Fast production-ready static web server |
| Superstatic | Enhanced static web server |
| darkhttpd | A simple web server written in C; only serves static content |
| simple-http-server | Simple static file server written in Rust |
| Static Web Server | High-performance and asynchronous web server |
| webfs | Simple http server for mostly static content. |
| quark | Small and simple HTTP GET/HEAD-only web server for static content |
| Websitino | Lightweight static file server for local development |
| static-file-server | Tiny, simple static file server |
Read our verdict in the software roundup.
LinuxLinks helps you discover the best free and open source software for Linux. Explore our extensive collection of recommended applications, including alternatives to popular proprietary software.We also publish software reviews, Linux tutorials, hardware reviews, free programming books and articles covering the wider open source community. Browse our Linux resources to discover more. Know a useful free and open source Linux application we haven't covered? Suggest a program for inclusion. Has your software been featured on LinuxLinks? Display one of our Featured on LinuxLinks badges on your website or GitHub README. |


Please read our Comment Policy before commenting.