<!DOCTYPE html>
<html lang="en-GB">

<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.linuxlinks.com/xmlrpc.php">


	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Hyper - terminal emulator built with web technologies - LinuxLinks</title>
	<meta name="description" content="Hyper is one of the newer terminal emulators available. It&#039;s built with web technologies – JavaScript, HTML, CSS. Free and open source software." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/" />
	<link rel="next" href="https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/2/" />
	<meta property="og:locale" content="en_GB" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Hyper - terminal emulator built with web technologies - LinuxLinks" />
	<meta property="og:description" content="Hyper is one of the newer terminal emulators available. It&#039;s built with web technologies – JavaScript, HTML, CSS. Free and open source software." />
	<meta property="og:url" content="https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/" />
	<meta property="og:site_name" content="LinuxLinks" />
	<meta property="article:published_time" content="2019-09-06T07:30:47+00:00" />
	<meta property="article:modified_time" content="2020-09-01T13:32:29+00:00" />
	<meta property="og:image" content="https://i0.wp.com/www.linuxlinks.com/wp-content/uploads/2019/09/terminal-500.png?fit=500%2C310&#038;ssl=1" />
	<meta property="og:image:width" content="500" />
	<meta property="og:image:height" content="310" />
	<meta name="twitter:card" content="summary_large_image" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.linuxlinks.com/#website","url":"https://www.linuxlinks.com/","name":"LinuxLinks","description":"The Linux Portal Site","potentialAction":[{"@type":"SearchAction","target":"https://www.linuxlinks.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-GB"},{"@type":"ImageObject","@id":"https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/#primaryimage","inLanguage":"en-GB","url":"https://i0.wp.com/www.linuxlinks.com/wp-content/uploads/2019/09/terminal-500.png?fit=500%2C310&ssl=1","width":500,"height":310,"caption":"Terminal Emulators"},{"@type":"WebPage","@id":"https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/#webpage","url":"https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/","name":"Hyper - terminal emulator built with web technologies - LinuxLinks","isPartOf":{"@id":"https://www.linuxlinks.com/#website"},"primaryImageOfPage":{"@id":"https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/#primaryimage"},"datePublished":"2019-09-06T07:30:47+00:00","dateModified":"2020-09-01T13:32:29+00:00","author":{"@id":"https://www.linuxlinks.com/#/schema/person/4770e5f50f65b33764e052ca2a0c67f6"},"description":"Hyper is one of the newer terminal emulators available. It's built with web technologies \u2013 JavaScript, HTML, CSS. Free and open source software.","inLanguage":"en-GB","potentialAction":[{"@type":"ReadAction","target":["https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/"]}]},{"@type":"Person","@id":"https://www.linuxlinks.com/#/schema/person/4770e5f50f65b33764e052ca2a0c67f6","name":"Steve Emms","image":{"@type":"ImageObject","@id":"https://www.linuxlinks.com/#personlogo","inLanguage":"en-GB","url":"https://secure.gravatar.com/avatar/750ae96c2af861c4c3619ad9e7ac244b?s=96&d=identicon&r=g","caption":"Steve Emms"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="LinuxLinks &raquo; Feed" href="https://www.linuxlinks.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinuxLinks &raquo; Comments Feed" href="https://www.linuxlinks.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinuxLinks &raquo; Hyper &#8211; terminal emulator built with web technologies Comments Feed" href="https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.12.2 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.12.2';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-1447713-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-1447713-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.linuxlinks.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='gambit-custom-fonts-css'  href='https://www.linuxlinks.com/wp-content/themes/gambit/assets/css/custom-fonts.css?ver=20180413' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.5.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='quads-style-css-css'  href='https://www.linuxlinks.com/wp-content/plugins/quick-adsense-reloaded/includes/gutenberg/dist/blocks.style.build.css?ver=2.0.12' type='text/css' media='all' />
<link rel='stylesheet' id='gambit-stylesheet-css'  href='https://www.linuxlinks.com/wp-content/themes/gambit/style.css?ver=1.6.5' type='text/css' media='all' />
<style id='gambit-stylesheet-inline-css' type='text/css'>
.site-description { position: absolute; clip: rect(1px, 1px, 1px, 1px); width: 1px; height: 1px; overflow: hidden; }
</style>
<link rel='stylesheet' id='genericons-css'  href='https://c0.wp.com/p/jetpack/8.9/_inc/genericons/genericons/genericons.css' type='text/css' media='all' />
<link rel='stylesheet' id='themezee-related-posts-css'  href='https://www.linuxlinks.com/wp-content/themes/gambit/assets/css/themezee-related-posts.css?ver=20160421' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://www.linuxlinks.com/wp-content/tablepress-combined.min.css?ver=36' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://www.linuxlinks.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.9/css/jetpack.css' type='text/css' media='all' />
<style id='quads-styles-inline-css' type='text/css'>
.quads-ad-label { font-size: 12px; text-align: center; color: #333;}
</style>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.1/wp-includes/js/jquery/jquery.js' id='jquery-core-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.9/_inc/build/related-posts/related-posts.min.js' id='jetpack_related-posts-js'></script>
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.linuxlinks.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxlinks.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.12.2' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://www.linuxlinks.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.linuxlinks.com/wp-content/themes/gambit/assets/js/html5shiv.min.js?ver=3.7.3' id='html5shiv-js'></script>
<![endif]-->
<script type='text/javascript' id='gambit-jquery-navigation-js-extra'>
/* <![CDATA[ */
var gambit_menu_title = "Menu";
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxlinks.com/wp-content/themes/gambit/assets/js/navigation.js?ver=20160719' id='gambit-jquery-navigation-js'></script>
<link rel="https://api.w.org/" href="https://www.linuxlinks.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.linuxlinks.com/wp-json/wp/v2/posts/38544" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.linuxlinks.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.linuxlinks.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.1" />
<link rel='shortlink' href='https://wp.me/p9swuV-a1G' />
<link rel="alternate" type="application/json+oembed" href="https://www.linuxlinks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxlinks.com%2Fhyper-terminal-emulator-web-technologies%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.linuxlinks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxlinks.com%2Fhyper-terminal-emulator-web-technologies%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};a2a_localize = {
	Share: "Share",
	Save: "Save",
	Subscribe: "Subscribe",
	Email: "Email",
	Bookmark: "Bookmark",
	ShowAll: "Show All",
	ShowLess: "Show less",
	FindServices: "Find service(s)",
	FindAnyServiceToAddTo: "Instantly find any service to add to",
	PoweredBy: "Powered by",
	ShareViaEmail: "Share via email",
	SubscribeViaEmail: "Subscribe via email",
	BookmarkInYourBrowser: "Bookmark in your browser",
	BookmarkInstructions: "Press Ctrl+D or \u2318+D to bookmark this page",
	AddToYourFavorites: "Add to your favourites",
	SendFromWebOrProgram: "Send from any email address or email program",
	EmailProgram: "Email program",
	More: "More&#8230;",
	ThanksForSharing: "Thanks for sharing!",
	ThanksForFollowing: "Thanks for following!"
};

(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type="text/javascript" src="https://www.linuxlinks.com/wp-content/plugins/quick-adsense-reloaded/assets/js/ads.js"></script><script type='text/javascript'>document.cookie = 'quads_browser_width='+screen.width;</script><style type='text/css'>img#wpstats{display:none}</style><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
					<style type="text/css" id="wp-custom-css">
				a:link,
a:visited {
  color: #00008B;
}
.widget-header {
	background: #00008B;
}

.site-title a:link,
.site-title a:visited {
	color: #00008B;
	
}

.header-main {
padding: 0.5em;
}

.main-navigation-menu ul {
	background: #00008B
}


.site-title {
	font-size: 32px;
	margin: 0.5em 0;
	line-height: 0;
}
.primary-navigation-wrap {
	background: #00008B;
}

body,
button,
input,
select,
textarea {
	color: #000000;
	font-size: 12px;
	font-size: 0.9375rem;
	font-family: Oxygen, Verdana, Georgia, Tahoma, Arial;
	line-height: 1.5;
}

code {
  padding: 2px 4px;
  font-size: 90%;
  color: #000000;
  background-color: #e2e2e2;
  border-radius: 2px;
}

/* Colored Content Boxes */

.box-blue,
.box-gray,
.box-green,
.box-grey,
.box-red,
.box-yellow {
	margin:0 0 25px;
	overflow:hidden;
	padding:20px;
	-webkit-border-radius: 10px;
        border-radius: 10px; 
}

.box-blue {
	background-color:#d8ecf7;
	border:1px solid #afcde3;
}

.box-gray {
	background-color:#e2e2e2;
	border:1px solid #bdbdbd;
}

.box-green {
	background-color:#d9edc2;
	border:1px solid #b2ce96;
}

.box-grey {
	background-color:#F5F5F5;
	border:1px solid #DDDDDD;
}

.box-red {
	background-color:#f9dbdb;
	border:1px solid #e9b3b3;
}

.box-yellow {
	background-color:#fef5c4;
	border:1px solid #fadf98;
}			</style>
		</head>

<body class="post-template-default single single-post postid-38544 single-format-standard wp-embed-responsive content-center">

	<div id="page" class="hfeed site">

		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		
		<header id="masthead" class="site-header clearfix" role="banner">

			<div class="header-main container clearfix">

				<div id="logo" class="site-branding clearfix">

										
			<p class="site-title"><a href="https://www.linuxlinks.com/" rel="home">LinuxLinks</a></p>

							
			<p class="site-description">The Linux Portal Site</p>

		
				</div><!-- .site-branding -->

				<div class="header-widgets clearfix">

					
				</div><!-- .header-widgets -->


			</div><!-- .header-main -->

		</header><!-- #masthead -->

		<div id="main-navigation-wrap" class="primary-navigation-wrap">

			<nav id="main-navigation" class="primary-navigation container navigation clearfix" role="navigation">
				<ul id="menu-test2" class="main-navigation-menu"><li id="menu-item-7623" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-7623"><a href="https://www.linuxlinks.com/">Home</a></li>
<li id="menu-item-56622" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-56622"><a href="https://www.linuxlinks.com/best-free-open-source-software/">Best Software</a></li>
<li id="menu-item-6330" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-6330"><a href="https://www.linuxlinks.com/links/">Linux Links Directory</a>
<ul class="sub-menu">
	<li id="menu-item-7559" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7559"><a href="https://www.linuxlinks.com/links/Distributions/">Distributions</a></li>
	<li id="menu-item-7560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7560"><a href="https://www.linuxlinks.com/links/Software/">Software</a></li>
	<li id="menu-item-7561" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7561"><a href="https://www.linuxlinks.com/links/UserGroups/">UserGroups</a></li>
	<li id="menu-item-7562" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7562"><a href="https://www.linuxlinks.com/links/Web/">Web Software</a></li>
	<li id="menu-item-7563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7563"><a href="https://www.linuxlinks.com/links/Java">Java</a></li>
</ul>
</li>
<li id="menu-item-31983" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31983"><a href="https://www.linuxlinks.com/category/reviews/">Reviews</a></li>
<li id="menu-item-12891" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12891"><a href="https://www.linuxlinks.com/award-winning-open-source-software/">OSS Awards</a></li>
<li id="menu-item-7639" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7639"><a href="https://www.linuxlinks.com/submit-news/">Contact Us</a></li>
</ul>			</nav><!-- #main-navigation -->

		</div>

		<div id="content-wrap" class="site-content-wrap clearfix">

			
			
			<div id="content" class="site-content container clearfix">

	<section id="primary" class="content-area">
		<main id="main" class="site-main" role="main">
				
		
<article id="post-38544" class="post-38544 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews category-software category-utilities tag-css tag-html tag-javascript tag-terminal-emulator tag-typescript">

	<img width="500" height="310" src="https://i0.wp.com/www.linuxlinks.com/wp-content/uploads/2019/09/terminal-500.png?resize=500%2C310&amp;ssl=1" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="Terminal Emulators" loading="lazy" data-lazy-src="https://i0.wp.com/www.linuxlinks.com/wp-content/uploads/2019/09/terminal-500.png?resize=500%2C310&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />
	<header class="entry-header">

		<h1 class="entry-title">Hyper &#8211; terminal emulator built with web technologies</h1>
		<div class="entry-meta"><span class="meta-date"><a href="https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/" title="8:30 am" rel="bookmark"><time class="entry-date published updated" datetime="2019-09-06T08:30:47+01:00">September 6, 2019</time></a></span><span class="meta-author"> <span class="author vcard"><a class="url fn n" href="https://www.linuxlinks.com/author/linuxlinks/" title="View all posts by Steve Emms" rel="author">Steve Emms</a></span></span><span class="meta-category"> <a href="https://www.linuxlinks.com/category/reviews/" rel="category tag">Reviews</a>, <a href="https://www.linuxlinks.com/category/software/" rel="category tag">Software</a>, <a href="https://www.linuxlinks.com/category/utilities/" rel="category tag">Utilities</a></span></div>
	</header><!-- .entry-header -->

	<div class="entry-content clearfix">

		<p>One of the reasons why I became hooked on Linux was the command line. The command line offers advantages day-to-day because of facets like its scalability, scriptability, simple design, and simple interface. At the command line, there’s so much power at my fingertips. Its continuing flexibility and power remain big draws to this day.</p>
<p>It’s true that some people consider the command line to be arcane and obsolete. They prefer graphical interfaces. And for non-technical people and beginners, few dispute good graphical user interfaces make life easier. But who doesn’t want the best of both worlds?</p>
<p>The power of the command line can be accessed on the desktop by using a terminal emulator. The terminal window allows the user to access a console and all its applications such as command line interfaces (CLI) and text user interface software. Even with sophisticated modern desktop environments packed with administrative tools, other utilities, and productivity software all sporting attractive graphical user interfaces, it remains the case that some tasks are best undertaken with the command line.</p>
<!-- WP QUADS Content Ad Plugin v. 2.0.12 -->
<div class="quads-location quads-ad2" id="quads-ad2" style="float:none;margin:-2px 0 -2px 0;text-align:center;">
<ins class="adsbygoogle"
   style="display:inline-block;min-width:300px;max-width:970px;width:100%;height:90px"
   data-ad-client="pub-6097899789476875"
   data-ad-slot="8494081652"></ins>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>

<p>The terminal emulator is a venerable but essential tool for everyone using the command line. There are so many terminal emulators available for Linux that the choice is, frankly, bamboozling.</p>
<p>This article looks at Hyper, one of the newer terminal emulators available. It&#8217;s built with web technologies – JavaScript, HTML, CSS. The goal of the project is to create a beautiful and extensible experience for command-line interface users, built on open web standards. Hyper is based on xterm.js, a front-end component written in TypeScript.</p>
<p>Hyper is cross-platform support running on Linux, macOS, and Windows. It boasts that it&#8217;s fully extensible. Let&#8217;s see how it fares.</p>
<h3>Installation</h3>
<p>There are packages available for Hyper in most popular Linux distributions. Or you can compile the source code:</p>
<p><code>$ git clone https://github.com/zeit/hyper.git</code><br />
<code>$ yarn</code><br />
<code>$ yarn run dist</code></p>
<p>This creates your own packages for Debian/Ubuntu and Fedora distributions. It also creates an AppImage, and a snap.</p>
<p>AppImage is a format for distributing portable software on Linux without needing superuser permissions to install the application. All that’s required is make the AppImage executable by typing:</p>
<p><code>$ chmod u+x Hyper 3.0.1-canary.4.AppImage</code></p>
<p style="text-align: right;"><a href="/hyper-terminal-emulator-web-technologies/2/"><strong>Next page: Page 2 &#8211; In Operation</strong></a></p>
<p><strong>Pages in this article:</strong><br />
<a href="/hyper-terminal-emulator-web-technologies/"><strong>Page 1 &#8211; Introduction / Installation</strong></a><br />
<a href="/hyper-terminal-emulator-web-technologies/2/"><strong>Page 2 &#8211; In Operation</strong></a><br />
<a href="/hyper-terminal-emulator-web-technologies/3/"><strong>Page 3 &#8211; Extensibility</strong></a><br />
<a href="/hyper-terminal-emulator-web-technologies/4/"><strong>Page 4 &#8211; Other Features</strong></a><br />
<a href="/hyper-terminal-emulator-web-technologies/5/"><strong>Page 5 &#8211; Summary</strong></a>
<!-- WP QUADS Content Ad Plugin v. 2.0.12 -->
<div class="quads-location quads-ad3" id="quads-ad3" style="float:none;margin:0px;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive - Text Only -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1180843672"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>


<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related articles</em></h3>
</div><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="addtoany_header">Share this article</div><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/" data-a2a-title="Hyper – terminal emulator built with web technologies"><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fhyper-terminal-emulator-web-technologies%2F&amp;linkname=Hyper%20%E2%80%93%20terminal%20emulator%20built%20with%20web%20technologies" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fhyper-terminal-emulator-web-technologies%2F&amp;linkname=Hyper%20%E2%80%93%20terminal%20emulator%20built%20with%20web%20technologies" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fhyper-terminal-emulator-web-technologies%2F&amp;linkname=Hyper%20%E2%80%93%20terminal%20emulator%20built%20with%20web%20technologies" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fhyper-terminal-emulator-web-technologies%2F&amp;linkname=Hyper%20%E2%80%93%20terminal%20emulator%20built%20with%20web%20technologies" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_linkedin" href="https://www.addtoany.com/add_to/linkedin?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fhyper-terminal-emulator-web-technologies%2F&amp;linkname=Hyper%20%E2%80%93%20terminal%20emulator%20built%20with%20web%20technologies" title="LinkedIn" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_mix" href="https://www.addtoany.com/add_to/mix?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fhyper-terminal-emulator-web-technologies%2F&amp;linkname=Hyper%20%E2%80%93%20terminal%20emulator%20built%20with%20web%20technologies" title="Mix" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fhyper-terminal-emulator-web-technologies%2F&amp;linkname=Hyper%20%E2%80%93%20terminal%20emulator%20built%20with%20web%20technologies" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_hacker_news" href="https://www.addtoany.com/add_to/hacker_news?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fhyper-terminal-emulator-web-technologies%2F&amp;linkname=Hyper%20%E2%80%93%20terminal%20emulator%20built%20with%20web%20technologies" title="Hacker News" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fwww.linuxlinks.com%2Fhyper-terminal-emulator-web-technologies%2F&amp;linkname=Hyper%20%E2%80%93%20terminal%20emulator%20built%20with%20web%20technologies" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>
		<div class="page-links">Pages: <span class="post-page-numbers current" aria-current="page">1</span> <a href="https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/2/" class="post-page-numbers">2</a> <a href="https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/3/" class="post-page-numbers">3</a> <a href="https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/4/" class="post-page-numbers">4</a> <a href="https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/5/" class="post-page-numbers">5</a></div>
	</div><!-- .entry-content -->

	<footer class="entry-footer">

		
			<div class="entry-tags clearfix">
				<span class="meta-tags">
					<a href="https://www.linuxlinks.com/tag/css/" rel="tag">CSS</a><a href="https://www.linuxlinks.com/tag/html/" rel="tag">HTML</a><a href="https://www.linuxlinks.com/tag/javascript/" rel="tag">JavaScript</a><a href="https://www.linuxlinks.com/tag/terminal-emulator/" rel="tag">terminal emulator</a><a href="https://www.linuxlinks.com/tag/typescript/" rel="tag">TypeScript</a>				</span>
			</div><!-- .entry-tags -->

				
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.linuxlinks.com/excellent-free-books-learn-scala/" rel="prev"><span class="screen-reader-text">Previous Post:</span>11 Excellent Free Books to Learn Scala</a></div><div class="nav-next"><a href="https://www.linuxlinks.com/musicalypse-audio-player-server-web-technologies/" rel="next"><span class="screen-reader-text">Next Post:</span>Musicalypse &#8211; audio player and server built with Web technologies</a></div></div>
	</nav>
	</footer><!-- .entry-footer -->

</article>

<div id="comments" class="comments-area">

	
	
		<header class="comments-header">

			<h2 class="comments-title">
				5 comments			</h2>

		</header><!-- .comment-header -->

		
		<ol class="comment-list">
					<li id="comment-799" class="comment even thread-even depth-1 parent">
			<article id="div-comment-799" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt src="https://secure.gravatar.com/avatar/a24bd22bcc2b433a590358c4af624707?s=56&#038;d=identicon&#038;r=g" class="avatar avatar-56 photo jetpack-lazy-image" height="56" width="56" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/a24bd22bcc2b433a590358c4af624707?s=112&#038;d=identicon&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/a24bd22bcc2b433a590358c4af624707?s=56&amp;is-pending-load=1#038;d=identicon&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/a24bd22bcc2b433a590358c4af624707?s=56&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/a24bd22bcc2b433a590358c4af624707?s=112&#038;d=identicon&#038;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' loading='lazy'/></noscript>						<b class="fn">Liam Mapson</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/#comment-799">
							<time datetime="2019-09-07T20:15:04+01:00">
								September 7, 2019 at 8:15 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Everyone who&#8217;s &#8220;in the market for a terminal built on web technologies&#8221;, please raise your hand&#8230;</p>
<p>No doubt I&#8217;ve missed something important, but what?</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-799' data-commentid="799" data-postid="38544" data-belowelement="div-comment-799" data-respondelement="respond" data-replyto="Reply to Liam Mapson" aria-label='Reply to Liam Mapson'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-800" class="comment byuser comment-author-luke-baker odd alt depth-2">
			<article id="div-comment-800" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt src="https://secure.gravatar.com/avatar/f336cae4230411eda626efb39d19aadf?s=56&#038;d=identicon&#038;r=g" class="avatar avatar-56 photo jetpack-lazy-image" height="56" width="56" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/f336cae4230411eda626efb39d19aadf?s=112&#038;d=identicon&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/f336cae4230411eda626efb39d19aadf?s=56&amp;is-pending-load=1#038;d=identicon&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/f336cae4230411eda626efb39d19aadf?s=56&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/f336cae4230411eda626efb39d19aadf?s=112&#038;d=identicon&#038;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' loading='lazy'/></noscript>						<b class="fn">Luke Baker</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/#comment-800">
							<time datetime="2019-09-07T20:56:39+01:00">
								September 7, 2019 at 8:56 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>It just means if you&#8217;re looking for a modern terminal&#8230;.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-800' data-commentid="800" data-postid="38544" data-belowelement="div-comment-800" data-respondelement="respond" data-replyto="Reply to Luke Baker" aria-label='Reply to Luke Baker'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-802" class="comment even thread-odd thread-alt depth-1 parent">
			<article id="div-comment-802" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt src="https://secure.gravatar.com/avatar/e3ceb2bd86378543dcc62a01974ad3d0?s=56&#038;d=identicon&#038;r=g" class="avatar avatar-56 photo jetpack-lazy-image" height="56" width="56" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/e3ceb2bd86378543dcc62a01974ad3d0?s=112&#038;d=identicon&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/e3ceb2bd86378543dcc62a01974ad3d0?s=56&amp;is-pending-load=1#038;d=identicon&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/e3ceb2bd86378543dcc62a01974ad3d0?s=56&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/e3ceb2bd86378543dcc62a01974ad3d0?s=112&#038;d=identicon&#038;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' loading='lazy'/></noscript>						<b class="fn">Erpitt</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/#comment-802">
							<time datetime="2019-09-09T18:56:38+01:00">
								September 9, 2019 at 6:56 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>If you might want to access a text based application from Linux on a remote network with a web server to provide access in this manner you might use this. Most young&#8217;uns wouldn&#8217;t know there&#8217;s trilliions of lines of code apps running out there that still manage huge petabytes of data all in text mode. IRS, Healthcare, lots of places. What I hate about articles on &#8220;Terminal Emulation&#8221; is they only deal with one emulation. VT100 compatible. If you want to write a true Terminal Emulator, emulate some terminals and do ADDS, IBM3090, or some other useful things instead of kiddie stuff.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-802' data-commentid="802" data-postid="38544" data-belowelement="div-comment-802" data-respondelement="respond" data-replyto="Reply to Erpitt" aria-label='Reply to Erpitt'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-803" class="comment odd alt depth-2">
			<article id="div-comment-803" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt src="https://secure.gravatar.com/avatar/1a69805602d18c2037dcb6883e5397f8?s=56&#038;d=identicon&#038;r=g" class="avatar avatar-56 photo jetpack-lazy-image" height="56" width="56" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/1a69805602d18c2037dcb6883e5397f8?s=112&#038;d=identicon&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/1a69805602d18c2037dcb6883e5397f8?s=56&amp;is-pending-load=1#038;d=identicon&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/1a69805602d18c2037dcb6883e5397f8?s=56&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/1a69805602d18c2037dcb6883e5397f8?s=112&#038;d=identicon&#038;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' loading='lazy'/></noscript>						<b class="fn">Phil S</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/#comment-803">
							<time datetime="2019-09-09T19:48:11+01:00">
								September 9, 2019 at 7:48 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Erpitt, if you want ADDS, IBM3090 or whatever, and think there&#8217;s a need to emulate them, go ahead and write a terminal emulator that meets your needs. The VT100 was very successful, and for a good reason.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-803' data-commentid="803" data-postid="38544" data-belowelement="div-comment-803" data-respondelement="respond" data-replyto="Reply to Phil S" aria-label='Reply to Phil S'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
		<li id="comment-804" class="comment byuser comment-author-linuxlinks bypostauthor even depth-2">
			<article id="div-comment-804" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt src="https://secure.gravatar.com/avatar/750ae96c2af861c4c3619ad9e7ac244b?s=56&#038;d=identicon&#038;r=g" class="avatar avatar-56 photo jetpack-lazy-image" height="56" width="56" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/750ae96c2af861c4c3619ad9e7ac244b?s=112&#038;d=identicon&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/750ae96c2af861c4c3619ad9e7ac244b?s=56&amp;is-pending-load=1#038;d=identicon&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/750ae96c2af861c4c3619ad9e7ac244b?s=56&#038;d=identicon&#038;r=g' srcset='https://secure.gravatar.com/avatar/750ae96c2af861c4c3619ad9e7ac244b?s=112&#038;d=identicon&#038;r=g 2x' class='avatar avatar-56 photo' height='56' width='56' loading='lazy'/></noscript>						<b class="fn">Steve Emms</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://www.linuxlinks.com/hyper-terminal-emulator-web-technologies/#comment-804">
							<time datetime="2019-09-09T20:10:42+01:00">
								September 9, 2019 at 8:10 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>This article is a review of Hyper.</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-804' data-commentid="804" data-postid="38544" data-belowelement="div-comment-804" data-respondelement="respond" data-replyto="Reply to Steve Emms" aria-label='Reply to Steve Emms'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		</ol><!-- .comment-list -->

		
	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Share your Thoughts					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/hyper-terminal-emulator-web-technologies/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=139785133&#038;postid=38544&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=1&#038;avatar_default=identicon&#038;greeting=Share+your+Thoughts&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=transparent&#038;lang=en_GB&#038;jetpack_version=8.9&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=e3fdc620368e93d9dd0e5e3154458cadd9efb22e#parent=https%3A%2F%2Fwww.linuxlinks.com%2Fhyper-terminal-emulator-web-technologies%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = true;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments -->
		
		</main><!-- #main -->
	</section><!-- #primary -->
	
		<section id="secondary" class="main-sidebar widget-area clearfix" role="complementary">

		
<!-- Quick Adsense Reloaded -->
<aside id="adswidget1-quick-adsense-reloaded-4" class="widget quads-ad1_widget clearfix"><div id="quads-ad1_widget" style="margin:0px 0px 0px 0px; padding:0px 0px 0px 0px; "><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Response -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1669640918"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center></div></aside>
		<aside id="recent-posts-2" class="widget widget_recent_entries clearfix">
		<div class="widget-header"><h3 class="widget-title">Recent Posts</h3></div>
		<ul>
											<li>
					<a href="https://www.linuxlinks.com/what-happened-three-promising-open-source-linux-terminal-emulators/">Now and Then: What happened to 3 promising open source Linux terminal emulators?</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/cryptonose-cryptocurrency-trading-tool/">Cryptonose &#8211; Cryptocurrency trading tool</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/best-free-open-source-music-players/">Best Free and Open Source Music Players</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/collaborativeediting/">Great Open Source Collaborative Editing Tools</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/best-free-open-source-groupware-software/">Best Free and Open Source Groupware Software</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/awow-ak41-mini-desktop-pc-teamviewer-linux/">AWOW AK41 Mini Desktop PC &#8211; TeamViewer with Linux &#8211; Week 10</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/linux-candy-free-and-open-source-software-fun/">Linux Candy &#8211; Free and Open Source Software that&#8217;s Fun</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/best-free-open-source-office-suites/">Best Free and Open Source Office Suites</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/linux-candy-edex-ui-sci-fi-computer-terminal-emulator-system-monitor/">Linux Candy: eDEX-UI &#8211; sci-fi computer terminal emulator and system monitor</a>
									</li>
											<li>
					<a href="https://www.linuxlinks.com/difftools/">6 Best Linux Diff Tools</a>
									</li>
					</ul>

		</aside>
<!-- Quick Adsense Reloaded -->
<aside id="adswidget1-quick-adsense-reloaded-9" class="widget quads-ad1_widget clearfix"><div id="quads-ad1_widget" style="margin:0px 0px 0px 0px; padding:0px 0px 0px 0px; "><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Response -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1669640918"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center></div></aside><aside id="jetpack-search-filters-6" class="widget jetpack-filters widget_search clearfix">			<div id="jetpack-search-filters-6-wrapper" >
		<div class="jetpack-search-form">
<form role="search" method="get" class="search-form" action="https://www.linuxlinks.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field"
			placeholder="Search &hellip;"
			value="" name="s"
			title="Search for:" />
	</label>
	<button type="submit" class="search-submit">
		<span class="genericon-search"></span>
		<span class="screen-reader-text">Search</span>
	</button>
<input type="hidden" name="orderby" value="relevance" /><input type="hidden" name="order" value="DESC" /></form>
</div></div></aside><aside id="text-13" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Luke&#8217;s Weekly Blog</h3></div>			<div class="textwidget"><div class="box-grey">
<p>Luke is currently writing his weekly blog about the <strong><a href="/category/blog/">AWOW AK41 Mini Desktop PC</a></strong>.</p>
<p>Other hardware: <strong><a href="/tag/raspberry-pi-4/">Raspberry Pi 4 single board computer</a></strong></p>
</div>
</div>
		</aside><aside id="text-14" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Data Science</h3></div>			<div class="textwidget"><div class="box-grey">
<p>Take our free interactive courses in data science. There&#8217;s our course for <strong><a href="/python-data-science/">Python using pandas and plotnine</a></strong>, and our course for <strong><a href="/r-rstudio-data-science/">R using ggplot2</a></strong>. </p>
<p>Get up to speed in 20 minutes. No programming knowledge required.</p>
</div>
</div>
		</aside><aside id="recent-comments-2" class="widget widget_recent_comments clearfix"><div class="widget-header"><h3 class="widget-title">Recent Comments</h3></div><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">I.Svirkova</span> on <a href="https://www.linuxlinks.com/datamelt/#comment-1231">DataMelt &#8211; scientific computation, data analysis and data visualization</a></li><li class="recentcomments"><span class="comment-author-link">Luke Baker</span> on <a href="https://www.linuxlinks.com/awow-ak41-mini-desktop-pc-astronomy/#comment-1223">AWOW AK41 Mini Desktop PC &#8211; Astronomy &#8211; Week 9</a></li><li class="recentcomments"><span class="comment-author-link">Rolf</span> on <a href="https://www.linuxlinks.com/awow-ak41-mini-desktop-pc-astronomy/#comment-1222">AWOW AK41 Mini Desktop PC &#8211; Astronomy &#8211; Week 9</a></li><li class="recentcomments"><span class="comment-author-link">selmf</span> on <a href="https://www.linuxlinks.com/raspberry-pi-4-chronicling-desktop-experience-reading-comics/#comment-1216">Raspberry Pi 4: Chronicling the Desktop Experience &#8211; Reading Comics &#8211; Week 12</a></li><li class="recentcomments"><span class="comment-author-link">Joseph Windell</span> on <a href="https://www.linuxlinks.com/dictionarytools/#comment-1215">6 Best Free Linux Dictionary Tools</a></li></ul></aside><aside id="text-12" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Programming Books</h3></div>			<div class="textwidget"><div class="box-grey">
<p>Read our <strong><a href="/excellent-free-programming-books/">curated lists of great free programming books</a></strong>. Learn <strong><a href="/excellent-free-books-learn-java/">Java</a></strong>, <strong><a href="/excellent-free-books-learn-c/">C</a></strong>, <strong><a href="/excellent-free-books-learn-python/">Python</a></strong>, <strong><a href="/excellent-free-books-learn-c-plus-plus/">C++</a></strong>, <strong><a href="/excellent-free-books-learn-c-sharp/">C#</a></strong>, <strong><a href="/excellent-free-books-learn-javascript/">JavaScript</a></strong>, <strong><a href="/excellent-free-books-learn-php/">PHP</a></strong>, and many more languages.</p>
<p>Alternatively, check out our series of <strong><a href="/category/tutorials/">great free programming tutorials</a></strong>.</p>
</div>
</div>
		</aside><aside id="archives-6" class="widget widget_archive clearfix"><div class="widget-header"><h3 class="widget-title">Archives</h3></div>		<label class="screen-reader-text" for="archives-dropdown-6">Archives</label>
		<select id="archives-dropdown-6" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://www.linuxlinks.com/2020/09/'> September 2020 </option>
	<option value='https://www.linuxlinks.com/2020/08/'> August 2020 </option>
	<option value='https://www.linuxlinks.com/2020/07/'> July 2020 </option>
	<option value='https://www.linuxlinks.com/2020/06/'> June 2020 </option>
	<option value='https://www.linuxlinks.com/2020/05/'> May 2020 </option>
	<option value='https://www.linuxlinks.com/2020/04/'> April 2020 </option>
	<option value='https://www.linuxlinks.com/2020/03/'> March 2020 </option>
	<option value='https://www.linuxlinks.com/2020/02/'> February 2020 </option>
	<option value='https://www.linuxlinks.com/2020/01/'> January 2020 </option>
	<option value='https://www.linuxlinks.com/2019/12/'> December 2019 </option>
	<option value='https://www.linuxlinks.com/2019/11/'> November 2019 </option>
	<option value='https://www.linuxlinks.com/2019/10/'> October 2019 </option>
	<option value='https://www.linuxlinks.com/2019/09/'> September 2019 </option>
	<option value='https://www.linuxlinks.com/2019/08/'> August 2019 </option>
	<option value='https://www.linuxlinks.com/2019/07/'> July 2019 </option>
	<option value='https://www.linuxlinks.com/2019/06/'> June 2019 </option>
	<option value='https://www.linuxlinks.com/2019/05/'> May 2019 </option>
	<option value='https://www.linuxlinks.com/2019/04/'> April 2019 </option>
	<option value='https://www.linuxlinks.com/2019/03/'> March 2019 </option>
	<option value='https://www.linuxlinks.com/2019/02/'> February 2019 </option>
	<option value='https://www.linuxlinks.com/2019/01/'> January 2019 </option>
	<option value='https://www.linuxlinks.com/2018/12/'> December 2018 </option>
	<option value='https://www.linuxlinks.com/2018/11/'> November 2018 </option>
	<option value='https://www.linuxlinks.com/2018/10/'> October 2018 </option>
	<option value='https://www.linuxlinks.com/2018/09/'> September 2018 </option>
	<option value='https://www.linuxlinks.com/2018/08/'> August 2018 </option>
	<option value='https://www.linuxlinks.com/2018/07/'> July 2018 </option>
	<option value='https://www.linuxlinks.com/2018/06/'> June 2018 </option>
	<option value='https://www.linuxlinks.com/2018/05/'> May 2018 </option>
	<option value='https://www.linuxlinks.com/2018/04/'> April 2018 </option>
	<option value='https://www.linuxlinks.com/2018/03/'> March 2018 </option>
	<option value='https://www.linuxlinks.com/2018/02/'> February 2018 </option>
	<option value='https://www.linuxlinks.com/2018/01/'> January 2018 </option>
	<option value='https://www.linuxlinks.com/2017/12/'> December 2017 </option>
	<option value='https://www.linuxlinks.com/2017/11/'> November 2017 </option>
	<option value='https://www.linuxlinks.com/2017/10/'> October 2017 </option>
	<option value='https://www.linuxlinks.com/2017/09/'> September 2017 </option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-6" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</aside>
	</section><!-- #secondary -->
	<section id="secondary" class="small-sidebar widget-area clearfix" role="complementary">

		<aside id="text-16" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Recommended Software</h3></div>			<div class="textwidget">
<table id="tablepress-612" class="tablepress tablepress-id-612">
<tbody>
<tr class="row-1">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-documents/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Documents.png" alt="Documents" width="64" height="64" class="alignnone size-full wp-image-56405" /><br />
<strong>Documents</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-internet/"><img src="https://i2.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Internet.png" alt="Internet" width="62" height="64" class="alignnone size-full wp-image-56419" /><br />
<strong>Internet</strong></a></center></td>
</tr>
<tr class="row-2">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-graphics/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/palette.png" alt="Graphics" width="64" height="64" class="alignnone size-full wp-image-56421" /><br />
<strong>Graphics</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-video/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Videos-icon.png" alt="Videos" width="64" height="64" class="alignnone size-full wp-image-56439" /><br />
<strong>Video</strong></a></center></td>
</tr>
<tr class="row-3">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-audio/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/classic.png" alt="Audio" width="64" height="64" class="alignnone size-full wp-image-56382" /><br />
<strong>Audio</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-productivity/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Productivity.png" alt="Productivity" width="64" height="64" class="alignnone size-full wp-image-56417" /><br />
<strong>Productivity</strong></a></center></td>
</tr>
<tr class="row-4">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-science/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Science.png" alt="Science" width="64" height="64" class="alignnone size-full wp-image-56410" /><br />
<strong>Science</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-education/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Education.png" alt="Education" width="64" height="64" class="alignnone size-full wp-image-56412" /><br />
<strong>Education</strong></a></center></td>
</tr>
<tr class="row-5">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-system-administration/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/System-Admin.png" alt="System Administration" width="64" height="64" class="alignnone size-full wp-image-56432" /><br />
<strong>System Admin</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-desktop/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/desktop.png" alt="Desktop" width="64" height="64" class="alignnone size-full wp-image-56403" /><br />
<strong>Desktop</strong></a></center></td>
</tr>
<tr class="row-6">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-utilities/"><img src="https://www.linuxlinks.com/wp-content/uploads/2020/09/Utilities.png" alt="Utilities" width="64" height="64" class="alignnone size-full wp-image-56423" /><br />
<strong>Utilities</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-development/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Programming.png" alt="Programming" width="64" height="64" class="alignnone size-full wp-image-56436" /><br />
<strong>Development</strong></a></center></td>
</tr>
<tr class="row-7">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-finance/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/finance.png" alt="finance" width="64" height="64" class="alignnone size-full wp-image-56396" /><br />
<strong>Finance</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-games/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Games-icon.png" alt="Games" width="64" height="64" class="alignnone size-full wp-image-56415" /><br />
<strong>Games</strong></a></center></td>
</tr>
<tr class="row-8">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-web-applications/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Web-apps.png" alt="Web Apps" width="64" height="64" class="alignnone size-full wp-image-56430" /><br />
<strong>Web Apps</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-security/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Security.png" alt="Security" width="64" height="64" class="alignnone size-full wp-image-56425" /><br />
<strong>Security</strong></a></center></td>
</tr>
<tr class="row-9">
	<td class="column-1"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-other-applications/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Other.png" alt="Other" width="64" height="64" class="alignnone size-full wp-image-56427" /><br />
<strong>Other</strong></a></center></td><td class="column-2"><center><a href="https://www.linuxlinks.com/best-free-open-source-software-documentation/"><img src="https://i1.wp.com/www.linuxlinks.com/wp-content/uploads/2020/09/Documentation.png" alt="Documentation" width="64" height="64" class="alignnone size-full wp-image-56434" /><br />
<strong>Documentation</strong></a></center><br />
</td>
</tr>
</tbody>
</table>
<!-- #tablepress-612 from cache -->
</div>
		</aside>
<!-- Quick Adsense Reloaded -->
<aside id="adswidget1-quick-adsense-reloaded-8" class="widget quads-ad1_widget clearfix"><div id="quads-ad1_widget" style="margin:0px 0px 0px 0px; padding:0px 0px 0px 0px; "><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Response -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1669640918"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center></div></aside><aside id="text-11" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Reviews</h3></div>			<div class="textwidget"><div class="box-grey">We&#8217;ve written tons of in-depth and <span data-dobid="hdw">completely</span> impartial reviews of open source software. <strong><a href="/category/reviews/">Read our reviews</a></strong>.
</div>
</div>
		</aside><aside id="text-15" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Get Involved</h3></div>			<div class="textwidget"><div class="box-grey"><a href="/sponsor-donate-linuxlinks/"><strong>Donate</strong></a> to LinuxLinks. Your help is appreciated.</p>
<p><strong><a href="/sponsor-donate-linuxlinks/">Sponsorship opportunities</a></strong> &#8211; Have a product or service you wish to promote?
</div>
</div>
		</aside><aside id="text-9" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Desktops</h3></div>			<div class="textwidget"><div class="box-grey"><strong><a href="/survey-linux-desktop-environments/">9 Best Desktops</a></strong><br />
<strong><a href="/excellent-kde-plasma-widgets/">24 KDE Widgets</a></strong><br />
<strong><a href="/excellent-gnome-desktop-extensions/">33 GNOME Extensions</a></strong><br />
<strong><a href="/linux-desktop-environments-pantheon-trinity-lxde/">Pantheon, Trinity, LXDE</a></strong></div>
</div>
		</aside><aside id="text-10" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">System Tools</h3></div>			<div class="textwidget"><div class="box-grey">
<p>Manage your system with <strong><a href="/essential-system-tools-excellent-ways-manage-system/">26 essential system tools</a></strong>. We&#8217;ve written an in-depth review for each of them.</p>
<p>We&#8217;re also writing a series of reviews showcasing <strong><a href="/outstanding-linux-utilities-maximize-productivity/">excellent utilities</a></strong>.</p>
</div>
</div>
		</aside><aside id="eu_cookie_law_widget-3" class="widget widget_eu_cookie_law_widget clearfix"><div
	class="hide-on-button"
	data-hide-timeout="30"
	data-consent-expiration="180"
	id="eu-cookie-law"
>
	<form method="post">
		<input type="submit" value="Close and accept" class="accept" />
	</form>

	Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
	<a href="https://www.linuxlinks.com/privacy-policy/" >
		Cookie Policy	</a>
</div>
</aside><aside id="meta-2" class="widget widget_meta clearfix"><div class="widget-header"><h3 class="widget-title">Meta</h3></div>
		<ul>
						<li><a rel="nofollow" href="https://www.linuxlinks.com/wp-login.php">Log in</a></li>
			<li><a href="https://www.linuxlinks.com/feed/">Entries feed</a></li>
			<li><a href="https://www.linuxlinks.com/comments/feed/">Comments feed</a></li>

			<li><a href="https://en-gb.wordpress.org/">WordPress.org</a></li>
		</ul>

		</aside><aside id="text-8" class="widget widget_text clearfix"><div class="widget-header"><h3 class="widget-title">Related</h3></div>			<div class="textwidget"><p><a href="/link-us/">Link us</a><br />
<a href="/faq/">FAQ</a><br />
<a href="https://www.forfoss.com/">ForFOSS.com</a><br />
<a href="https://www.ossblog.org/">OSSBlog.org</a><br />
<a href="/privacy-policy/">Privacy Policy</a></p>
</div>
		</aside>
	</section><!-- #secondary -->
	

		</div><!-- #content -->

	</div><!-- #content-wrap -->

	
	<div id="footer" class="site-footer-wrap">

		<footer id="colophon" class="site-footer container clearfix" role="contentinfo">

			<div id="footer-text" class="site-info">
				
	<span class="credit-link">
		Copyright 2018-2020 LinuxLinks.com	</span>

				</div><!-- .site-info -->

			
		</footer><!-- #colophon -->

	</div>

</div><!-- #page -->

<script type="text/javascript">
   if(typeof quadsOptions !== 'undefined' && typeof wpquads_adblocker_check_2 
  === 'undefined' && quadsOptions.quadsChoice == 'ad_blocker_message'){

  var addEvent1 = function (obj, type, fn) {
      if (obj.addEventListener)
          obj.addEventListener(type, fn, false);
      else if (obj.attachEvent)
          obj.attachEvent('on' + type, function () {
              return fn.call(obj, window.event);
          });
  };
   addEvent1(window, 'load', function () {
      if (typeof wpquads_adblocker_check_2 === "undefined" || wpquads_adblocker_check_2 === false) {
          highlight_adblocked_ads();
      }
  });

   function highlight_adblocked_ads() {
      try {
          var ad_wrappers = document.querySelectorAll('div[id^="quads-ad"]')
      } catch (e) {
          return;
      }

      for (i = 0; i < ad_wrappers.length; i++) {
          ad_wrappers[i].className += ' quads-highlight-adblocked';
          ad_wrappers[i].className = ad_wrappers[i].className.replace('quads-location', '');
          ad_wrappers[i].setAttribute('style', 'display:block !important');
      }
  }
 }

(function() {
//Adblocker Notice Script Starts Here
var curr_url = window.location.href;
var red_ulr = localStorage.getItem('curr');
var modal = document.getElementById("quads-myModal");
var quadsAllowedCookie =  quadsgetCookie('quadsAllowedCookie');

if(typeof quadsOptions !== 'undefined' && typeof wpquads_adblocker_check_2 
  === 'undefined' ){

  if(quadsAllowedCookie!=quadsOptions.allow_cookies){
    quadssetCookie('quadsCookie', '', -1, '/');
    quadssetCookie('quadsAllowedCookie', quadsOptions.allow_cookies, 1, '/');
  }

  if(quadsOptions.allow_cookies == 2){
    if( quadsOptions.quadsChoice == 'bar' || quadsOptions.quadsChoice == 'popup'){
        modal.style.display = "block";
        quadssetCookie('quadsCookie', '', -1, '/');
    }
    
    if(quadsOptions.quadsChoice == 'page_redirect' && quadsOptions.page_redirect !="undefined"){
        if(red_ulr==null || curr_url!=quadsOptions.page_redirect){
        window.location = quadsOptions.page_redirect;
        localStorage.setItem('curr',quadsOptions.page_redirect);
      }
    }
  }else{
    var adsCookie = quadsgetCookie('quadsCookie');
    if(adsCookie==false) {
      if( quadsOptions.quadsChoice == 'bar' || quadsOptions.quadsChoice == 'popup'){
          modal.style.display = "block";
      }
      if(quadsOptions.quadsChoice == 'page_redirect' && quadsOptions.page_redirect !="undefined"){
        window.location = quadsOptions.page_redirect;
        quadssetCookie('quadsCookie', true, 1, '/');
      }
    }else{
      modal.style.display = "none";
    }
  }
}

function quadsgetCookie(cname){
    var name = cname + '=';
    var ca = document.cookie.split(';');
    for (var i = 0; i < ca.length; i++) {
        var c = ca[i].trim();
        if (c.indexOf(name) === 0) {
            return c.substring(name.length, c.length);
        }
    }
    return false;
}
function quadssetCookie(cname, cvalue, exdays, path){
  var d = new Date();
  d.setTime(d.getTime() + (exdays*24*60*60*1000));
  var expires = "expires="+ d.toUTCString();
  document.cookie = cname + "=" + cvalue + ";" + expires + ";path=/";
}

var span = document.getElementsByClassName("quads-cls-notice")[0];
if(span){
  span.onclick = function() {
    modal.style.display = "none";
    document.cookie = "quads_prompt_close="+new Date();
    quadssetCookie('quadsCookie', 'true', 1, '/');
  }
}

window.onclick = function(event) {
  if (event.target == modal) {
    modal.style.display = "none";
    document.cookie = "quads_prompt_close="+new Date();
    quadssetCookie('quadsCookie', 'true', 1, '/');
  }
}
})();
//Adblocker Notice Script Ends Here
</script>

<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.9/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.1/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.9/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js' id='eu-cookie-law-script-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.9/modules/widgets/search/js/search-widget.js' id='jetpack-search-widget-js'></script>
<script type='text/javascript' src='https://www.linuxlinks.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.0.0' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.1/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://www.linuxlinks.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6' id='akismet-form-js'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=139785133&postid=38544&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=identicon&greeting=Share+your+Thoughts&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_GB&jetpack_version=8.9&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=e3fdc620368e93d9dd0e5e3154458cadd9efb22e#parent=https%3A%2F%2Fwww.linuxlinks.com%2Fhyper-terminal-emulator-web-technologies%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=139785133&postid=38544&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=identicon&greeting=Share+your+Thoughts&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_GB&jetpack_version=8.9&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=e3fdc620368e93d9dd0e5e3154458cadd9efb22e#parent=https%3A%2F%2Fwww.linuxlinks.com%2Fhyper-terminal-emulator-web-technologies%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202037.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.9',blog:'139785133',post:'38544',tz:'1',srv:'www.linuxlinks.com'} ]);
	_stq.push([ 'clickTrackerInit', '139785133', '38544' ]);
</script>

</body>
</html>

<!-- Cached by WP-Optimize (gzip) - https://getwpo.com - Last modified: Sat, 12 Sep 2020 16:21:56 GMT -->
