Newbies What Next ? News Forums Calendar


 Category Gateway
More Options

LinuxLinks News
 · 9 Excellent Open Source Configuration Management Applications
 · A Beginner’s Introduction to Linux
 · Simon Tatham’s Portable Puzzle Collection – Games for the Brain
 · Captain Holetooth – Explorative 2D Platform Game for Kids
 · Taisei – A Classy, Frenetic Shoot’em Up Game in the Style of The Touhou Project
 · YouTube Channel
 · Minilens – Fun Open Source Puzzle Platform Game
 · Wizznic! – Highly Addictive Open Source Puzzle Game
 · Success! Beelink S1 Running Linux – Courtesy of the Open Source Community
 · Beelink S1 Mini PC and Linux – Comedy Gold

LinuxLinks Login



Click here
to start your own
Link collection!

Click to Visit

My LinuxLinks
 My LinuxLinksMyLinks  FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

PXE-T01: TFTP error: file not found

Post new topic   Reply to topic Forum Index -> Networking / Security
View previous topic :: View next topic  
Author Message
Terry Becker
Private Penguin
Private Penguin

Joined: 25 May 2005
Posts: 15

PostPosted: Wed Feb 08, 2006 7:56 pm    Post subject: PXE-T01: TFTP error: file not found Reply with quote

PXE booting a client from a Linux server, the client gets the IP add. from the server, then the error.
To make sure it's not a hardware prob., I copied the server to another PC & booted a different client.
I was running atftpd in daemon mode & then I installed xinet & the error is still the same.
The log & ps shows that atftpd started & was running & now shows xinet is also working.
Log shows dhcpd gets 3 boot requests & then it acknowledges, then log says atftpd is serving the file: /tftpboot/pxelinux.0 on port 2070 & then on port 2071, which arn't standard PXE ports (4011 & 69 are). I've tried to find an app. that will give me the port number of the incoming boot request but no luck.
I've tried many different dhcpd.conf & xinet.conf arrangements & all it produces is different errors.

the dhcpd.conf:

allow booting;
allow bootp;
ddns-update-style none;
# ignore-client-updates;
default-lease-time 600;
max-lease-time 7200;
# range;
option subnet-mask;
option broadcast-address;
option routers;
option domain-name-servers;
option domain-name "";

subnet netmask {

# Group the PXE bootable hosts together
group {
# option vendor-class-identifier "PXEClient";
filename "/tftpboot/pxelinux.0";

host puppypc {
hardware ethernet 00:50:da:71:1f:c8;

The line: option vendor-class-identifier "PXEClient"; just causes another error, weard because that's what dhcp3 is suppost to use.

the xinet.conf I copied from a web page:

instances = 60
log_type = SYSLOG authpriv
log_on_success = HOST PID
log_on_failure = HOST
cps = 25 30
service tftp
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -v -s /tftpboot
# server_args = -s /tftpboot -u nobody
disable = no

There's a: /tftpboot link that points to: /mnt/home/tftpboot, I've checked it & it's good.
Server says it's serving the file (so it's found it), but the client doesn't get it, maybe after a good dhcp session, suddenly they're talking on different ports when the tftp transfer starts?
I don't see any way to tell xinet & atftpd to use a different port, even if I knew which one the client's using.
This is an oddball Linux distro, but I'm using Debian stable binaries, it seems to work well.
I've tried posting elsewhere with no luck, thought I might try you guys & see if anyone knows PXE & network booting.
If there's any other info that would help, say so & I'll try to get it to post here.
Back to top
View user's profile Send private message

Captain Penguin
Captain Penguin

Joined: 23 Aug 2002
Posts: 512
Location: Québec, Canada

PostPosted: Sun Feb 19, 2006 8:07 pm    Post subject: Reply with quote

I'm not sure what the problem is in your case, but normally, it's a problem with the tftpserver. The problem is that the server is not giving the correct directory to the client (ex /tftpboot ) by default, the client has to think that his "/" is the "/tftpboot/" on the server

you should test the "tftp" client on your server and check if you're in the correct directory and if you can see the files. Sometimes, ftp/tftp servers don't follow symlink

And about your ports thing, I'm not sure what's happening :s

sorry if that's not a lot of help
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic Forum Index -> Networking / Security All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2002 phpBB Group
Built with GeekLog and phpBB
Comments to the webmaster are welcome
Copyright 2009 - All rights reserved